LayItLow.com Lowrider Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter #1
I am having problems getting my car started. I have a 1987 305 with a #1406 edelbrock performer seris carb. The engine is getting spark. It's also getting gas to the carb but not gas to the motor. If anybody can help me it would be great.
 

·
Face Puncher
Joined
·
25,975 Posts
float might be stuck, filter might be clogged, might be an obstruction in the needle/ seat, lots of shit to look for
 

·
Triple OG
Joined
·
11,046 Posts
when you say that the carb gets gas do the jets actually spray the gas or did you take off the hose and there was gas comming out?
 

·
Registered
Joined
·
237 Posts
Discussion Starter #7
Yeah I took the hose off and gas came out but then i dumb it straight into the carb after that and still didn't start.
 

·
Premium Member
Joined
·
11,540 Posts
there could be 3048204802384 things wrong here.

Did you just put the carb on? How was the engine running BEFORE it wouldn't start? Is it trying to start just wont stay running? Or is it not firing at all?

Also, how do you know its not getting gas to the motor? DId you look at it spray the gas into the intake? Is it spraying? If its not, then pouring a little in the carb should have caused it to fire unless you got 2 things wrong here.

We need more info.
 

·
Registered
Joined
·
237 Posts
Discussion Starter #9
I just put the motor in last May and it's been running great for awhile but ever since the last week it's been flooding out alot and now just two days ago in won't even start at all. It's just not firing over. I did put gas in the carb and it still didn't fire over. Carb getting gas though from fue pump. Also spark plugs getting spark. I can't figure it out. Help Please! I can use any help.
 

·
Premium Member
Joined
·
49,409 Posts
Have you pulled the plugs out to see if they're flooded? Do that first, if they are clean them, then re-install and try it. If there's no gas on the plugs, pump the fuck out of it until it starts and get it running
 
1 - 10 of 10 Posts
Top