LayItLow.com Lowrider Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #1 ·
On the steering wheel column after it comes out of the fire wall there is a cup underneath the steering gear jacket, I think it has u-joint assembly. From the cup to the steering wheel its loose but from the cup down its solid, it doesnt move. Its the piece right above the intermediate shaft assembly. Does anybody know what that piece is and does anyone know where I can order it? Thank you.
 

·
Javy
Joined
·
546 Posts
can u show a pic? does your sterring wheel pull in and out or up and down movement? up and down there is 2 bushings/bearings. in and out the spring and shaft can be adjusted and tightened up
:thumbsup::thumbsup::thumbsup::thumbsup:
 

·
Registered
Joined
·
389 Posts
Right, there are two metal blocks that fit on pins coming out of the shaft (the shaft from the firewall). The blocks fit in the wide slots stamped into the cup. If those blocks are missing or worn, you get lots of play. As far as I know, this coupler is not reproduced, so if your's is trashed, you will have to get a junkyard piece. They do reproduce the rubber seal, though. In any event, it is worth taking apart and giving it some fresh grease. These are one of those parts that never seem to get any service, and the grease petrifies after a few decades.
 

·
Registered
Joined
·
870 Posts
Not sure if you guys are talking about the steering wheel coupler? mine broke off completely once it was my first near death experience with my 63 lol... i found a brand new one near my house at this one shop i replaced it with i could probably try to find you one and do a direct sale trough paypal? lmk
 

·
420Puffin
Joined
·
761 Posts
you might have probs in the steering box too. its worth checking it out whlie your already there.
 

·
Riding Sboccolati
Joined
·
2,183 Posts
Old thread i know, but couldnt seem to find a better one to ask for advice.
So, my socio from Unity here in italy has a 64, last saturday drove to a show about 50miles from his place and told me he couldnt get past 30mph or the steering wheel would start a death shake of the twisted wrist kind :)
His aligmnet is ok, rims are new-ish (not bent) so my intuition lends toward a loose steering component of some kind or the column coupler, althou im not even remotley familiar with those cars and he seems to be a little clueless on the problem even thou hes a mechanically inclined guy.
Told him to check for a loose A arm as it happened to me before and caused an ILL vibration after 20 than seemed like a self destruct function...but apparently all is good in that dept.

Any input appreciated. Also whatever details you need to help just say and i'll see to answer them.
And thanx.
 
1 - 13 of 13 Posts
Top