LayItLow.com Lowrider Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6,814 Posts
Discussion Starter #1
im clueless why it bogs down when i step on the gas like it's getting to much air or something...my 64 has a 327 from a 68 camaro intake manifold heads are all original ...i have a edelbrock 1406 600 cfm electric choke carb on it with adapter plate,full length headers...any ideas why it would be doing this? anyone ever had this same problem?



 

·
i dont feel tardy
Joined
·
20,934 Posts
needs tuned


edelbrocks are bad for it thats why i prefer quadrajets
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter #3
my cousin came by and tuned it one day,guess maybe he didn't tune it right
 

·
Registered
Joined
·
2,032 Posts
carburator
:yessad: :yessad: :yessad: :yessad:
 

·
i dont feel tardy
Joined
·
20,934 Posts
Originally posted by HydroCutlass86@Jan 19 2010, 01:34 AM~16335945
my cousin came by and tuned it one day,guess maybe he didn't tune it right
probably not edelbrocks are tricky
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter #6
cool thanks least it's nothing major :cool: ...just have to find someone to tune it right
 

·
i dont feel tardy
Joined
·
20,934 Posts
Originally posted by HydroCutlass86@Jan 19 2010, 02:01 AM~16336086
cool thanks least it's nothing major :cool: ...just have to find someone to tune it right
drive it up here :cheesy:
 

·
Registered
Joined
·
4,161 Posts
Originally posted by Firefly@Jan 19 2010, 06:49 AM~16336557
Either that or your fuel pump is busted (or fuel filter clogged/line pinched somewhere)
X2 any trash in the filter?? Clogged, or collapsed lines from the gas tank!?? :cool:
 

·
Registered
Joined
·
6,814 Posts
Discussion Starter #10
Originally posted by Firefly+Jan 19 2010, 06:49 AM~16336557-->
Either that or your fuel pump is busted (or fuel filter clogged/line pinched somewhere)
[/b]

<!--QuoteBegin-81.7.TX.
@Jan 19 2010, 01:18 PM~16338875
X2 any trash in the filter?? Clogged, or collapsed lines from the gas tank!??  :cool:

i think the fuel pump might be old,fuel filter is new and has new lines and gas tank
 

·
Registered
Joined
·
1,030 Posts
First make sure the choke isn't closed all the time causing no air to be able to enter the carb. It may be hanging up on the air cleaner base or just adjusted wrong.

ALSO

Get it to idle at operating temp, set timing with advance disconnected and plugged to 8-10 BTDC, set idle to about 650 RPM in gear. Connect the vacuum advance.

This will give you a decent place to start
 

·
Registered
Joined
·
3,516 Posts
I would try adjusting your power piston.... that little arm on the front right side of the carb. It comes out the box in the middle hole, move it to the upper one, drive the car, if it didnt help or made it worse, move it to the lowest one, if that doesn't help, go back to the middle and check something else. I had this problem with my 1406 on my 283... the power piston was shootin in too much gas when I stepped on it so i had to adjust it to have less fuel shootin in :puffin:
 

·
Registered
Joined
·
4,161 Posts
The neoprene hose that connects the filler tube to the gas tank rots and is easily forgotten!! Replace that to reduce trash in the tank!! :cool:
 
1 - 14 of 14 Posts
Top