LayItLow.com Lowrider Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
hey i recently converted my rear brakes to disc on my 64, and now after about 10-15 minutes of driving the brakes get tight and kina lock up. this causes the car to over heat. anyone had this problem? could it be my booster or a line getting to hot and cuasing fluid to not work ? when it happens all the rims are HOT! and the brake pedal cant be pushed in it is stuck out all the way. the booster is new and so are rear discs, any sugestions? to much vacum? line to close to motor??
 

·
Triple OG
Joined
·
11,046 Posts
man thats kina weird.

I'm not sure of the answer to this one...but I'll give you a few Ideas of what I would check if I were you.


check the lines for some kind of blockage.
don't hurt to double check fluid..
check where the line is..
what kind of rims do you have? I have heard of rims not clearing the caliper and maybe that is why its getting hot and locking up...

sorry I couldn't help much but nobody else posted so I figured I would try to help you out..
 

·
Registered
Joined
·
19,958 Posts
Do you have a proportioning valve inline in your system and if so is it the disk/disk one or is it the disk/drum one?????
 

·
Registered
Joined
·
301 Posts
Discussion Starter #6
all wheel disc , and yes i have a proporton valve, and i have plenty of fluid. and i have to drive it for like 20 mins before it happens. i was wondering if i needed a differnt brake fluid, maybe one that could stand higher temps? maybe. i jacked i up and whhels spins freely when brakes are cold. who knows, thanks for opinions
 

·
Registered
Joined
·
14,848 Posts
DO YOU SEE ALOT OF BRAKE DUST ? IF THEY ARE TIGHT JUST FROM NORMAL DRIVING,I WOULD CHECK TO SEE IF THE CALIPERS ARE PROPERLY ALIGNED AND THE ROTOR IS SOMEWHAT CENTERED. OR TRY A DIFFERENT BRAND OF PADS
 

·
Registered
Joined
·
301 Posts
Discussion Starter #10
yeah when i put the booster on the linkagae i had to adapt for the booster. and i got it working. the brakes are fine for 10- 20 minutes, i can drive along take it out of gear and the car will keep going nothing begins to slow it down, there is no resistance, then bam alll at once it get tight and tighter the whole thing takes like 1 minute once it starts to happen.
 

·
Face Puncher
Joined
·
25,975 Posts
sounds like the brakes arent totally releasing, and building heat as you drive.
try shortening the length of the brake push rod, or even the length of the rod between the booster and the master cylinder.
if all alse fails, call the company that manufactured it and see what they say.
it has absolutely nothing to do with the type of fluid you are running.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #13
i have it on jacks now and the fronts spins real easy i got to check backs. and if i drive and put it in nutreul the car will just keep gliding, so i dont think the brakes are draging so i know the pedal is coming out enough. i dont know. thanks for help any othere suggestions are appreciated.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #16
locking themselves up. must be heating up i guess, i havent had time to check them to much since i posted this, i need advice for when i do. i wont have a chance for another week, but it happens without me pushing pedal.
 

·
Registered
Joined
·
9,403 Posts
Originally posted by HaterProof64@Aug 17 2005, 06:05 PM~3644825
locking themselves up.  must be heating up i guess, i havent had time to check them to much since i posted this, i need advice for when i do. i wont have a chance for another week, but it happens without me pushing pedal.
it's heat

get making it hot should make the fluid gas with makes it compressable and spongy at the pedal
 
1 - 20 of 27 Posts
Top