LayItLow.com Lowrider Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
having problems with my 64 it wont start battery is good alternator is good my headlights work but it wont crank can anyone give me some advice of what u think might be wrong??

thank you
 

·
Registered
Joined
·
2,151 Posts
If there is no clicking when you turn the key your neutral safety switch might be broken. It is on the steering collum on the bottom near the middle, looks like a cresent shaped electrical box with a couple wires connecting. Basically kills the ignition in case you try to start your car in gear so it doesn't jump.
 

·
Registered
Joined
·
75 Posts
few things to try ,1) starter or starter solenoid , 2)hot wire going from battery to starter grounding out againt exhaust manifold , 3) Ignition and of course the the neutral safety switch,if it turns check out your points,coil and for spark or fuel pump,since you didn't leave any detail on what is going on "just don't start"
 

·
SWANG
Joined
·
242 Posts
my nuetral safety switch is mess up so i jus hold the shiftr up wen i try to crank it easy way to decide if thats the problem u can always pull off a the cap to see if distributer if getting spark also...if u have points just save ur self the trouble and convert.
 

·
Face Puncher
Joined
·
25,975 Posts
Also try wiggling the main harness bulkhead at the firewall, sometimes those connections get lose and the car just dies out on ya.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #6
thank you guys for the 411 i will try all the things u guys are telling me to check

what the car does is it doesnt click u turn key and nothing no noise nada just the gen light goes on

i got a good battery and starter ...


u guys talk about holding the shifter up well my car would turn on like that but not it doesnt

i will keep u guys posted if i fix the problem
if u guys more ideas let me know
 

·
Registered
Joined
·
149 Posts
Discussion Starter #7
i think i found the sterring colum box (those it look like kinda lround with 2 plugs connected to colum well i turned in the key and still the GEN light ups even Brighter helpHELP HELP
 

·
Registered
Joined
·
496 Posts
did you try jumping it at the starter . with a screwdriver? you have to have the ignition on . then do it. do you know what i mean? ...if it cranks over then it might be your wire from the starter to the firewall and it runs along the fire wall over towards the steering column...kinda looks like a braided wire...probably the issue...check it out. mine was loose one time not making a good connection....just trying to kick in some more help homeboy...
 

·
Registered
Joined
·
149 Posts
Discussion Starter #11
FOUND THE PROBLEM GUYS
IT WAS THE neutral safety switch GOT IT AT KRAGENS FOR ABOUT 22 BUCKS
WANNA THANK ALL U GUYS THAT GAVE ME THERE HELPFULL ADVISE

THANK YOU
 
1 - 13 of 13 Posts
Top