LayItLow.com Lowrider Forums banner
1 - 8 of 8 Posts

·
SWANG
Joined
·
242 Posts
Discussion Starter · #1 ·
i changed out everything on my motor from oil pan to distributer the timing is set and i have a new eldlbrick carb the car starts and sometimes willl stay on but will eventually start reving really high and sometimes u can see the valve covers flexing. what could be wrong with it .............pleas pleas help.............
 

·
Registered
Joined
·
2,151 Posts
Valve cover flexing doesn't sound good. Could be a number of problems from a shit torque converter to a out of alignment crank or electrical or fuel problem.
 

·
SWANG
Joined
·
242 Posts
Discussion Starter · #3 ·
well if it helps my homeboy who i bought it from parked it driven n i bought it from him and replaced everything on it fuel pump included n im just usin a gas can for now till i clean the actual tank
 

·
SWANG
Joined
·
242 Posts
Discussion Starter · #6 ·
Originally posted by pink63impala@Mar 5 2010, 07:26 PM~16808506
Is the pcv vAlve hooked up and a breater on the other side
the pcv valve is hooked up and the vacume from the ccarb is goin to the distributer....or is that wrong...i also have another valve type thing wer a vacume line could go on the intake manifold not sure were it goes
 

·
Registered
Joined
·
389 Posts
The vavle covers flexing does sound weird. Are they flexing back and forth as it runs, or just expanding or contracting as the engine runs? Is this the original type motor or a newer 350?

I would try taking off the oil fill cap or breather and see if that makes a difference when you try to run it.
 
1 - 8 of 8 Posts
Top