LayItLow.com Lowrider Forums banner
1 - 7 of 7 Posts

·
Stay True
Joined
·
147 Posts
Discussion Starter · #1 ·
sup everybody, i have an 81 regal limited and im pushin 2 treo ssi with a mmats d1400 and i have a us amps md42 pushin the highs and mids. i also have a 1.5 fared capacitor, all running off a kenwood deck. ive upgraed the big 3 (batt to alt./ batt ground to chasis./ and power to starter. with 2 guage) i have a 140 amp alternator. my battery is an everstart maxx ( like 2 years old) and my lights still dim. im thinking replace the batt with optima but in your experiences what better yellow or red??


 

·
Registered
Joined
·
154 Posts
First off, ditch the cap. You should see less voltage drop without it. Your lights dimming are the signs of an overstressed charging system and the cap is just putting more of a load on it. I'd put a yellowtop under the hood and look at possibly adding a second AGM battery. You'll probably need to upgrade the alternator too if this doesn't solve your problem.
 

·
Registered
Joined
·
4,510 Posts
x3.. in theory you need 1 amp per 10 watts so 1000rms watts would meanyou need addl 100 amp on alt.. a second battery may be needed as well..
 

·
Registered
Joined
·
2,308 Posts
sup everybody, i have an 81 regal limited and im pushin 2 treo ssi with a mmats d1400 and i have a us amps md42 pushin the highs and mids. i also have a 1.5 fared capacitor, all running off a kenwood deck. ive upgraed the big 3 (batt to alt./ batt ground to chasis./ and power to starter. with 2 guage) i have a 140 amp alternator. my battery is an everstart maxx ( like 2 years old) and my lights still dim. im thinking replace the batt with optima but in your experiences what better yellow or red??
Get the yellow top, throw the neverstart away.
 

·
Registered
Joined
·
271 Posts
Get a 2.0 cap the dim will stop..no matter how good your battery if your pushing some serious shit it will dim..I got a 2.0 and I don't see no dim..the cap is good its take some power off the battery and alternator ...and im pushing 6400 in my amps alone..
 

·
THE ENTREPRENEUR
Joined
·
3,714 Posts
First off, ditch the cap. You should see less voltage drop without it. Your lights dimming are the signs of an overstressed charging system and the cap is just putting more of a load on it. I'd put a yellowtop under the hood and look at possibly adding a second AGM battery. You'll probably need to upgrade the alternator too if this doesn't solve your problem.
Pretty much exactly what i was going to say....def need a extra batt in the trunk....batcap is the best bet
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top