LayItLow.com Lowrider Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10,333 Posts
Discussion Starter · #1 ·
I have a 92 Brougham and Im having some engine issues.
The car is running to rich,its getting to much gas.

The Map sensor was changed and that did nothing.
One of my batterie cabled is lose,and the car has cut off a few time,so since everything is computerised,maybe it hasnt reset its self?

The car runs fine for about 10 minutes and the it starts smoking and gas fumes like crazy.

Can anyone help me out on this??
 

·
Registered
Joined
·
2,468 Posts
Originally posted by Psta@Sep 21 2005, 09:20 AM~3856104
I have a 92 Brougham and Im having some engine issues.
The car is running to rich,its getting to much gas.

The Map sensor was changed and that did nothing.
One of my batterie cabled is lose,and the car has cut off a few time,so since everything is computerised,maybe it hasnt reset its self?

The car runs fine for about 10 minutes and the it  starts smoking and gas fumes like crazy.

Can anyone help me out on this??
Have you replaced the 02 sensors? They can make a car run too rich. An exhaust leak ahead of the 02's such as a manifold or doughnut gasket can also make the car run rich as well.
 

·
Registered
Joined
·
10,333 Posts
Discussion Starter · #3 ·
Originally posted by Cadillac Bob@Sep 21 2005, 11:54 AM~3857242
Have you replaced the 02 sensors? They can make a car run too rich. An exhaust leak ahead of the 02's such as a manifold or doughnut gasket can also make the car run rich as well.
Ill checc,thanks Bob!
 

·
Registered
Joined
·
10,333 Posts
Discussion Starter · #4 ·
ttt
 

·
Registered
Joined
·
10,333 Posts
Discussion Starter · #6 ·
Originally posted by ogbrkboy@Sep 22 2005, 09:55 PM~3868713
Any codes or check engine lights?
no
 

·
Registered
Joined
·
3,195 Posts
My younger brother had the same problem with his 92 Brougham, it was something in the throttle body,I didnt want to troubleshoot it so I just replaced the whole thing. It fixed the problem
 
1 - 7 of 7 Posts
Top