LayItLow.com Lowrider Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #1 ·
Sup yall? I'm running 2 pumps to the back. I changed the check valve of the left rear pump. However, after 5 min.s the truck started to drop again. I closed the slow down valve and raised it back up. something weird started to happen.. the truck stayed up for 20 sec.s and dropped for an inch or so..then after 20 -30 sec.s it started to dropped again..so if the check valve I used is bad, eventhougth it's a new one. why is it dropping like that? why is it not a continouse dropping?
Thanks
 

·
True-S Mike
Joined
·
251 Posts
are they chrome check valves? <---- if so, they leak ALOT!
if not, when you put them in, it may have ripped the teflon and a peice of it got caught in the way. but useally whenever i had that drop, then hold, then drop, then hold effect, it was the dump cartridge rings, but you said the slowdown is closed, so i dont know
 

·
Registered
Joined
·
709 Posts
take off that cylinder and check the seals if you put the check valve on backwards your truck shouldnt go up at all.
 

·
True-S Mike
Joined
·
251 Posts
Originally posted by 81low@Jul 21 2005, 10:15 PM
take off that cylinder and check the seals if you put the check valve on backwards your truck shouldnt go up at all.
[snapback]3454337[/snapback]​
fuck! im slippin............. i didnt even think about the cylenders
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #7 ·
I'm sure I did put the check valve the right way..
I think what juggalo4life has said is true and a peice of the teflon tape stuck in the way..I'll take it out and clean it..
I think the cylinder o-rings are fine 'case there is no oil drops under the truck except the ones from me overfilling the tanks :uh:
 
1 - 7 of 7 Posts
Top