LayItLow.com Lowrider Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3,640 Posts
Discussion Starter #1
Today i put new brake pads on my daily driver. I took the old ones off, depressed the caliper piston (whatever thats called), then changed the pads. Well once i got everything back together, when i drive i have hardly any braking power. It feels as if i'm only getting braking from the rear brakes. Does anyone know what could be the problem?? thanks for the help guys.
 

·
Registered
Joined
·
243 Posts
man i dunno , but i have sum probs too , when i drive ders an annoying ass sound that comes from the bak brakes. till i start breaking den it goes away , and i got no idea , tommorow i think ima go take it to ma ol bois job to see wut it is. but either way if anyone knows tell me
 

·
\m/ WTF? FTW! \m/
Joined
·
13,648 Posts
Originally posted by BaSSmAsTeR@Aug 28 2003, 06:26 PM
man i dunno , but i have sum probs too , when i drive ders an annoying ass sound that comes from the bak brakes. till i start breaking den it goes away , and i got no idea , tommorow i think ima go take it to ma ol bois job to see wut it is. but either way if anyone knows tell me
hooked on phonics?????????????
 

·
Registered
Joined
·
3,640 Posts
Discussion Starter #4
anyone???? this shit is annoying cuz driving my cadillac everyday is expensive so i kinda wanna get this fixed soon without taking the car to a brake place.
 

·
Registered
Joined
·
1,484 Posts
did you open the cap on the master cylinder when you compressed the piston.......if so did you check the fluid afterwards cuz it will come out if you compress the pistons too fast............i would check the brake fluid level man ...............good luck

i did the brakes on my lac three weeks ago and no problems :biggrin:
 

·
Registered
Joined
·
10,665 Posts
Originally posted by ogcaddy+Aug 28 2003, 06:34 PM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (ogcaddy @ Aug 28 2003, 06:34 PM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--BaSSmAsTeR@Aug 28 2003, 06:26 PM
man i dunno , but i have sum probs too , when i drive ders an annoying ass sound that comes from the bak brakes. till i start breaking den it goes away , and i got no idea , tommorow i think ima go take it to ma ol bois job to see wut it is. but either way if anyone knows tell me
hooked on phonics?????????????[/b][/quote]
:roflmao: :roflmao: :roflmao:

you know I was about to say the same shit
 

·
Registered
Joined
·
3,640 Posts
Discussion Starter #9
well, i took it somewhere this morning and they told me that the power booster has gone bad. He said he could tell that cuz the way the brake pedal/brakes react and that the brakes were working becuase the rotors were warm after he drove it. Well i got the part i need but the fun part is going to be trying to change it when its something i've never done or even attempted before. I'll be having some fun come tomorrow morning :0
 

·
Registered
Joined
·
3,640 Posts
Discussion Starter #11
Originally posted by Foompla@Aug 29 2003, 09:44 PM
if it was the booster, itd be very difficult to stop. You know that pads have to be broken right?
it is difficult to stop, like nearly impossible, it feels as if i have almost 0 braking power at all.
 

·
Registered
Joined
·
15,195 Posts
Originally posted by 83Coupe+Aug 29 2003, 10:52 PM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (83Coupe @ Aug 29 2003, 10:52 PM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--Foompla@Aug 29 2003, 09:44 PM
if it was the booster, itd be very difficult to stop.  You know that pads have to be broken right?
it is difficult to stop, like nearly impossible, it feels as if i have almost 0 braking power at all.[/b][/quote]
good luck then :) hope you get it fixed quick
 

·
Registered
Joined
·
3,640 Posts
Discussion Starter #13
:angry: :angry: :angry: :angry: :angry: :angry: Everything was going well until i went to get the last 2 nuts off that hold the booster to the firewall. Well, theres 2 linkages that are connected to the steering column that make it impossible to get to the 2 nuts, even with a swivel socket and an extension bar :angry: :angry: now i just need to figure out how to get those linkages out of the way.
 
1 - 13 of 13 Posts
Top