LayItLow.com Lowrider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7,961 Posts
mine knocks a bit too when idling...the old guy I bought it off says it knocked like that since he drove it off the lot in 84...and he had all the service invoices to prove it! I wouldn't worry about it. Ticking sound is prob a lifter going or a bent pushrod...if it isn't causing a misfire under power - wouldn't sweat that either

charging problem your gonna have to test voltage starting at the alt and working your way
 

·
Registered
Joined
·
11,533 Posts
knocking and a ticking are to different sounds....someone would have to listen to the motor to let whats wrong...knocking a more loud bad, bad, noise is usually a bad rod or main journal...a more anoying tick tick tick noise is a bad lifter, or worn rocker arm...both are not good. i would have someone who knows what they are doing look at the motor and get several opinions to. when you changed your oil did you see any metal dust in it, do you still have you old oil filter..cut it open and see if there is any metal dust in it. i had 13's and a 1:1 ratio final drive on my gp..i drove the car long distance to shows and at the end of the summer the motor started knocking cause i wound it out to much over a long period of time...needless to say i am replacing both the engine with a v8 and the trans with a overdrive unit.

as far as your batt problem..get a volt meter and start the car...test the batt voltage while it is running..it should be about 13-14 volts if the alt is working properly...if its 12-12.8 then its mostly likely not working
 
1 - 4 of 4 Posts
Top