LayItLow.com Lowrider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7,982 Posts
Discussion Starter · #1 ·
car: 1993 Cadillac Fleetwood rwd 5.7ci tbi fuel injection

problem: car will crank but have a hard time starting if it even starts. if i press the gas slightly when i turn the ign. on it starts without any problems and runs great. each and everytime i start the car i need to press the gas SLIGHTLY not even giving it gas like a carbed engine just press the gas a tiny bit and it fires up perfect. no gas pedal no start.

any ideas? buddy of mine said it sounds like ign module is bad. what do you guys think?

btw. i have not given the car a full tune up. fyi.
 

·
Registered
Joined
·
1,967 Posts
whats the fuel pressure ?? i would make sure the flow and pressure is good . I am not sure the correct pressure on a tbi
 

·
Registered
Joined
·
4,425 Posts
Clean the throttle body, it has carbon build up between the body and the butterfly valve. It sound that you need just a little bit of air, to get first started. Clean the throttle body with carb spray and a rag hold the pedal to the foor while you are cleaning it "WITH THE CAR OFF."
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter · #5 ·
Originally posted by gzking@Dec 28 2008, 12:19 PM~12543358
whats the fuel pressure ??  i would make sure the flow and pressure is good . I am not sure the correct pressure on a tbi
i think its 6-8psi but ill check thanks dawg
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter · #6 ·
Originally posted by kandylac@Dec 28 2008, 12:44 PM~12543467
Clean the throttle body, it has carbon build up between the body and the butterfly valve. It sound that you need just a little bit of air, to get first started. Clean the throttle body with carb spray and a rag hold the pedal to the foor while you are cleaning it "WITH THE CAR OFF."
:thumbsup: will do homie thanks
 

·
Registered
Joined
·
241 Posts
It's more likely that your Idle Air Control(IAC) motor is bad or the wiring or connector is loose it's the round cylinder on the passenger side of the TB with the four wire connector.

the other thing is the Throttle Position Sensor(TPS) , that's adjustable but I've always replaced them.
 

·
Registered
Joined
·
3,195 Posts
Originally posted by mrratchet@Jan 1 2009, 09:06 AM~12576264
It's more likely that your Idle Air Control(IAC) motor is bad or the wiring or connector is loose it's the round cylinder on the passenger side of the TB with the four wire connector.

the other thing is the Throttle Position Sensor(TPS) , that's adjustable but I've always replaced them.
Do you have to set the new TPS or is it set already?
 
1 - 8 of 8 Posts
Top