LayItLow.com Lowrider Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
When i lock up the front end the left cylinder gets stuck, it'll move real real real slow then come down after a certain point. it only happens when it wants. any1 have some idea what it might be. the fronts are 8" reds in case any1 was curious
 

·
Registered
Joined
·
21,472 Posts
may be the plastic teflon peice with the o-rings on the shaft part,,,,i wouldnt think the shaft would be bent on a 8''...its not too common
 

·
Registered
Joined
·
21,472 Posts
i dont think its bent,,,if it was bent,,,it wouldnt do it sometimes,,and then,,sometimes not,,,,it would do all the time....im thinkin a combo of the o-rings,,or teflon rings binding up
 

·
Registered
Joined
·
8,414 Posts
I'm thinking the brass wiper seal thingy? I would inspect that along with the seals/o-rings.

cylinder could be bent, how old is the cylinder?
 

·
Registered
Joined
·
21,472 Posts
Originally posted by AndrewH@Aug 29 2006, 08:19 PM~6069543
I'm thinking the brass wiper seal thingy? I would inspect that along with the seals/o-rings.

cylinder could be bent, how old is the cylinder?
yeah tru...

but,,,,,even the older Reds cylinders,,the shafts are strong,,its that tapered top peice where the fitting goes that usually messes up on them,,,,
 

·
Registered
Joined
·
69 Posts
smae thing was happin to my monte on left front check ground wire on your dump mine kept coming lose i thought it was seals and shit to replaced them and still doing it then i checked my ground now its fine
 

·
Registered
Joined
·
17,780 Posts
looses the hose at the pitting of the cylinder if it goes down then the cylinder is fine, if not its bent of the seal broken...........if it goes down check your dump for power, or your slowdown may be broke too
 
1 - 10 of 10 Posts
Top