LayItLow.com Lowrider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
hey iam having problems with my new showtime set up ( i had cce) and its like dumpin wroung or sumthing sounds like its going back though the pump head and its really slow going down at times and i got my slow down valves all the way open and i cant figure it out please respond asap....thanks
 

·
Registered
Joined
·
7,083 Posts
lock up the car max, tighten the slowdown max and if it still dumps it's most likely the checkvalve.
 

·
Registered
Joined
·
4,551 Posts
you could have contamination in there, burr or dirt, that could cause both problems.. the one being the check valve sounds stuck open (caused from contamination) and the dump problem that could still be casue by contamination...

latley theres been a VERY COMMON problem being the cylinders are made by a few different companies. One of the copanies aren't cleaning out the cylinders before assembly and theres contamination wrecking dumps, scoring the insides....



If I were you, I'd flush the system..... See how mush shit comes out.... It might fix your small problem before it becomes unfixable....


The ONE MAJOR CAUSE OF HYDRAULIC EQUIPMENT FAILURE is not mantaining it.. KEEP IT CLEAN, especially after an install if you had the hoses exposed and weld spatter gets in.. could be anything not nesasarily the company putting out a bad product...



Last edited by Volv_lo at Jan 9 2004, 08:45 AM
 
1 - 4 of 4 Posts
Top