LayItLow.com Lowrider Forums banner

1 - 4 of 4 Posts

·
SELL 0UT
Joined
·
2,737 Posts
Discussion Starter #1
ok a while back all my outter lights stopped working.. i last time i remembver them working was before i pressure washed my engine and something sparked from down by the starter. turned out to be a uncovered wire.. now that wire has a short in it from somewhere but cant find out where
i checked all the fuses and the fuse panel and the BATT spot in the panel and when i ground one end of my test light and touch the other to where the constant power is supposed to be it lights up showing its grounded out..

dont know where to start
 

·
SELL 0UT
Joined
·
2,737 Posts
Discussion Starter #2
ok i was just told that its probably a fusible link thats near my starter... but whats a fusible link look like..
what do i look for ..
and when i find it how do i test it?
 

·
Registered
Joined
·
778 Posts
a fusible link is inline with the pos. battery cable. These are usually before the fuse block. If you have power at the block then that may not be your problem.

They look just like a butt connector or something that is made into the wire. When they go out you can usually see some signs of it being burned, and if you pull on both ends you can pull the wires out of the fusible link insulator.


From your description it does not sound like this is your problem.

Why do you think you have a short to ground somewhere? does it keep popping fuses?
 

·
SELL 0UT
Joined
·
2,737 Posts
Discussion Starter #4
the wire pulled out of the link with ease when i found it.. but the issue i have now is that my key broke off in my steering column.. so for now ima wrap the bandana round it and do what it do til i get this parts car.

the place in the fuse box thats usually constant power is now a ground.. thats the main problem im having.. when i run a test light fron the positive of the batterys to the constant power in the fuse box is lights up showing that its grounded out.
 
1 - 4 of 4 Posts
Top