LayItLow.com Lowrider Forums banner

1 - 16 of 16 Posts

·
EnViUs
Joined
·
22,931 Posts
Discussion Starter · #1 ·
was just crusin...didnt hit any switches...heard a whining noise....went to pull over and the pump motor exploded in flames...fuckin huge ass flames....got it put out...heres the damage....what caused this...noid did fry...or at least i dont think it did because i didnt even hit a switch and after the fire was out i touched the noid and it was cold....











 

·
EnViUs
Joined
·
22,931 Posts
Discussion Starter · #9 ·
Originally posted by dwnlow4lif@Sep 24 2005, 06:41 PM~3878542
:0
And you just got those put in...thats to bad bro...sorry to see that
i know..dam cheap ass switches from prohopper...lol..oh well i think it was just a motor...hopefully
 

·
Registered
Joined
·
8,414 Posts
I used to have a ride with some old switches some of them would stick and i always thought it was my noids and after haveing my passenger hold down the dump while i ran to the trunk, i would always get home and find another old non-carling switch to replace.

damn,it must have went for a while though if it made a brand new motor all crispy like that.better check your pumphead seals too while your at it.
 

·
EnViUs
Joined
·
22,931 Posts
Discussion Starter · #11 ·
Originally posted by AndrewH@Sep 24 2005, 07:45 PM~3878871
I used to have a ride with some old switches some of them would stick and i always thought it was my noids and after haveing my passenger hold down the dump while i ran to the trunk, i would always get home and find another old non-carling switch to replace.

damn,it must have went for a while though if it made a brand new motor all crispy like that.better check your pumphead seals too while your at it.
ya i could bearly hear it...low sqeauling niose...really weird.....how do i check my pumphead seals? i turned the pump umside down and no fluid came out...so i dont know for sure if i need another one or not
 

·
Registered
Joined
·
2,716 Posts
were you rolling locked up? when it happend? maybe the switch stuck on the last hit when you locked it up. could be noids too, bad ground, loose connection etc.
 

·
EnViUs
Joined
·
22,931 Posts
Discussion Starter · #13 ·
Originally posted by Swingin80Lincoln@Sep 24 2005, 08:59 PM~3879114
were you rolling locked up? when it happend? maybe the switch stuck on the last hit when you locked it up. could be noids too, bad ground, loose connection etc.
yeah the front was locked...i had hit the switch maybe 2 mins before the fire started...all connections are tight, i know i got a good ground...i use the Prohopper HD noids and ususly when those fry there freakin hot afterwards...mine was bearly warm....so im leaning toward stuck switch...should i replace that switch?
 

·
Registered
Joined
·
2,716 Posts
i have never heard of those noids sticking? were the batterys low? its possible that its a bad noid, but the switches are starting to look like the problem. 10 switch box or what you got?
 

·
EnViUs
Joined
·
22,931 Posts
Discussion Starter · #15 ·
Originally posted by Swingin80Lincoln@Sep 24 2005, 09:23 PM~3879185
i have never heard of those noids sticking? were the batterys low? its possible that its a bad noid, but the switches are starting to look like the problem. 10 switch box or what you got?
ya batts were fully charged the night before...and the noid is new...10 switch box that came with the kit..
 
1 - 16 of 16 Posts
Top