LayItLow.com Lowrider Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
2,151 Posts
Discussion Starter #1
My heat in my 1980 fleetwood brougham isn't working at all :-/ if i move the little sliding thing (you can see it in this picture: http://www.swooh.com/lorenzo/cadillac/pers...alcaddy0020.jpg ) to the "red" zone (80-85) it's supposed to stop blowing from the vents and start blowing from the bottom, where my feet are... it used to work about 2 years ago, but now it just keeps blowing cold air out! this happens even when the engine's been running for a long time, and i've tried it even on hot days and it does the same thing.

i can't afford to take the car to get diagnosed and fixed, so if any of you have some ideas of things i can try, please let me know and let me know how i can fix it and i'd appreciate it. Thanks again :)
~Lorenzo
 

·
Registered
Joined
·
2,523 Posts
Hey hows it going lorenzo? When the car is to blow warm ait ir opens a valve that lets the hot water go into the car and trough the heater core into the car. Then a fan blows ait through that little radiator in the car and hot air comes out. If you have a manual for the car, see where the heater valve is and see if you can open it up by hand or see why its not doing it on its own.
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #3
hey, thanks for the help! :)

hmmmm i don't have a manual... i've been restoring the car (it was wrecked in a junkyard) so i don't really know anything else about it :-/

www.f1f3.com/cadillac/
there's pictures in there, and most of the information that i know ;) LOL

any ideas where the heater core could be?



Last edited by Stealth at Nov 30 2003, 12:58 PM
 

·
Registered
Joined
·
2,523 Posts
Its usually located in all that bullshit under the dash near where your feet are. But its the valve that lets the hot water in that I think is the problem. If you can find it and slide the little lever on it to open the flow, you can have your nice warm heater back.
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #5
OK, but sliding the lever "on", is just a temporary fix, isn't it? wouldn't it be on all the time then?
 

·
Registered
Joined
·
2,523 Posts
Yeah, it would until it was figured out why its not working properly.
 

·
Registered
Joined
·
2,523 Posts
You would just be opening a valve to allow the heat to enter the car. You can still control the fan to turn the heat on right?
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #8
yeah, fan speed can be adjusted still (although i do have a vaccum leak in the actual switch, where i turn the fan on/off, high/low, heat, cool, etc., because when i put it on "OFF", it still blows cold air (not sure if it's airconditioned air, might just be outside air) out the foot vents... so i really can't turn everything off. also i hear the "pssssssssshhhhhhhhh" of escaping air (pretty loud) at some positions, and sometimes when i put it on "high" it stays on "low", etc... just problems with the actual switch, but i can't find one like i have, so i'm just stuck with it :(
 

·
Registered
Joined
·
2,523 Posts
I know exactly what you mean about everything you just described. When your trying to turn it to a spot there sounds like a huge rush of air is trying to escape out of it. And where the off is not really off, untill you move it alittle past that position then it turns off. And high is med speed, then when you put it on high, its actually low. I know bro, your not alone on that stuff. :biggrin: . It sounds like you may need a whole new assembly for that car. But try to get to that valve somehow and get the heat to defrost your windows.
 

·
Registered
Joined
·
12,920 Posts
do you get any heat at all?


if not there is a vacuum controled valve under the hood on the heater lines sometimes they stick and don't let coolant flow thru the heater core....i had this problem on mine and just replaced the vavle with a flushing T....
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #11
Originally posted by 1LOWCHERO@Nov 30 2003, 07:19 PM
It sounds like you may need a whole new assembly for that car. But try to get to that valve somehow and get the heat to defrost your windows.
Wait, a whole new assembly?! It can't be that expensive though, right? because my A/C does blow good, and cold, and the switch works sometimes, i'm sure it's not THAT big of a deal!!! I'll try looking into my heater core shit first though.

Thanks for the help 1lowchero and Chris :) :)
 

·
Registered
Joined
·
6,115 Posts
I have three 1980 caddies & the only thing thats ever went wrong with my heat was the part right there on your dash. I had a few of them go bad. I used the one on my parts car, then had to use the one one the fleetwood I'm workin on for the sedan to drive so I finally bought a spare off of ebay for like $20-25.
 

·
Registered
Joined
·
6,115 Posts
Originally posted by Stealth@Dec 2 2003, 09:38 PM
so i should just go and replace the switch first?
bEFORE YOU REPLACE IT TAKE IT OUT & LOOK AT THE CONCACTS ON THE BACK & LOOK FOR ANY BURN MARKS.

SOME OF THE ONES I REPLACED ACTUALLY HAD A TINY BURN MARK ON ONE OF THE CONTACT POINTS.
 

·
Registered
Joined
·
343 Posts
man if your from texas then what the hell do u need heat for? if u lived in canada like i do then i could undertsand it cause it does get a little nipply here in the winter, but texas? common man
 

·
Registered
Joined
·
15,195 Posts
Originally posted by old_school_48@Dec 3 2003, 02:09 AM
man if your from texas then what the hell do u need heat for? if u lived in canada like i do then i could undertsand it cause it does get a little nipply here in the winter, but texas? common man
them southeners think anything below 60 is freezing :biggrin:
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #17
are you kidding me? for the last few days it's been in the early 40s in the mornings... i'm driving with a fucking blanket over me, because i can't turn the A/C off either ;)
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #18
burn marks? what would that mean? that i have a short somewhere?

Doesn't it work on vacuum too? cause when i move the switch i hear a "psssshhhhhh" of air escaping
 

·
Registered
Joined
·
15,195 Posts
Originally posted by Stealth@Dec 3 2003, 09:41 PM
are you kidding me? for the last few days it's been in the early 40s in the mornings... i'm driving with a fucking blanket over me, because i can't turn the A/C off either ;)
only 40? pssh. I drive with the window down on the highway when its only 40.. :cheesy:
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter #20
true, but i'll bet you northerners can't take the heat like we do.

105 degrees farenheit and 97% humidity
... THATS when you drive with the windows open ;) LOL

OK, so let's get back on topic... anyone want to give me a step by step thing of what i should do/check?
 
1 - 20 of 25 Posts
Top