LayItLow.com Lowrider Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
218 Posts
Discussion Starter #1
i have a problem with the tough-up from devilbiss ega-503.
i only used it once and took it apart to clean it, few months later i wanted to use it again but now it blows bubbles in the paintcan, and thus the sprayfan is fluttering Also without paintcan when i hold my finger slighty against where it should suck, it blows a little against the tip of my finger.
One thing i noticed is that the needle is not precisely in the middle of the cap. But i dont know how i can adjust this.. the needle itself is straight as fuck.
i have tried everything, cleaned the whole thing out, took it apart a zilion times
i even made an x-ray picture of it at work, but i still cant find anything.
Maybe that number 2 thing (needle packing) is fucked???

Does anybody have any idea what the problem could be, hope i can solve it, i really like this little gun.

thanks a lot
here a some pics.





 

·
Registered
Joined
·
5,774 Posts
yeah! junk it!!!!!!!!!
j/k pull the cap off and try tighteneing on the fluid tip just a lil more,did you check to see if it had a o ring on it? maybe it stiffend up,what you clean it with?hows your pattern?
 

·
Registered
Joined
·
5,774 Posts
see the number 5? thats what im talking about,also the needle doesnt have to stay center when cap is off!
 

·
Registered
Joined
·
218 Posts
Discussion Starter #6
thanks chico, .. well i will junk that shit if i get nowhere :biggrin:

nah, well there was a O-ring, but one time i might have overtighten it, so its kinda flat now, which might reduce airflow to the horncaps :ugh:
it was not stiff, and i cleaned the everything with thinner. then regreased the nessecery parts.
the patterns looks allright, a nice oval, but its not comming out continueusly
but like this



but i dont think its any of the problems discribed.
yesterday i ordered a repair kit (including number 5 and 2). hope it gets here asap.
 
1 - 6 of 6 Posts
Top