LayItLow.com Lowrider Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I blew the fluid tank off of my left pump for the front. I put the tank back on after I checked the pumphead and the dump for that pump and visually they looked fine so I don't know what the problem could be??? I hooked everything back up, filled the tank and tried it again and I blew the tank off again!!! Do I need a new dump??? Pump??? Something blocking a hose??? Has this happened to anyone else??? I could really use some help.
Thanx
 
T

·
Guest
Joined
·
0 Posts
Sound like u have been filling the tank with oil while the car was up, when filling the tank with oil the car has to be dumped......
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I always fill the tanks when the car is fully dumped so I don't think that is it. I've got a 4 pump/ 4 dump setup. Obviously 2 pumps for the front and 2 for the back. This is just a thought, that maybe one pumphead isn't moving the fluid out of the tank and the rest of the fluid keeps getting dumped back in the tank plus the fluid from the right pump is being introduced to the left pump tank from the right pump, this all adding up to a blown off tank!!!???
I don't know for sure but this has happened twice now, and my mind is going a mile a minute trying to diagnose this problem. It doesn't help that I've got the cutty for sale, there's a guy who said he'd buy it today as soon as I can get the fronts to work. Any help would be much appreciated.
Thanx
sKoWT
 

·
Registered
Joined
·
19 Posts
Unless one dump is not working on the side thats not blowing off I would have to say it's just to much fluid in the tanks. How many hose's do you have to the front?
 

·
Registered
Joined
·
3,085 Posts
Originally posted by sKoWTeMpiRE.com@Oct 8 2003, 11:19 PM
I always fill the tanks when the car is fully dumped so I don't think that is it. I've got a 4 pump/ 4 dump setup. Obviously 2 pumps for the front and 2 for the back. This is just a thought, that maybe one pumphead isn't moving the fluid out of the tank and the rest of the fluid keeps getting dumped back in the tank plus the fluid from the right pump is being introduced to the left pump tank from the right pump, this all adding up to a blown off tank!!!???
I don't know for sure but this has happened twice now, and my mind is going a mile a minute trying to diagnose this problem. It doesn't help that I've got the cutty for sale, there's a guy who said he'd buy it today as soon as I can get the fronts to work. Any help would be much appreciated.
Thanx
sKoWT
THEIR IS NO WAY TO GET FLUID FROM THE RIGHT FRONT PUMP TO THE LEFT FRONT PUMP.
WITH A 4 PUMP 4 DUMP SETUP, THEIR IS NO POSSIBLE WAY.
IF THEIR IS THEN THATS YOUR PROBLEM!
 
1 - 5 of 5 Posts
Top