LayItLow.com Lowrider Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4,452 Posts
Discussion Starter #1
so i just finished hooking up my mtx 81000d amp (1000 watt) to my 2 mtx 8000 subs and everything was good. later on i go to show my cousin (because they bump way better than with my 1800 watt pyramid -i know i know, sorry-), and the woofer on the right side sounds like it has something up against it. so i open up the trunk and check it out and there is nothing wrong witht he speaker from the outside.

i have a battery isolated in my trunk and thats what im running the amp off of. it had a charger on it when i went to go turn on my radio. maybe the surge power from the amp blew out the voice coil or something? my friend wired up the subs, i believe at 2 ohm. do any of you know what the problem can be? can it be fixed? about how much would it cost?

any of you know what kind of warranty mtx come with? (i think i've had them for about 2 years or so, but bought them over the net and never turned in any paper work to mtx or nothing).

say if there is no cure for the sub, what pair of 12" (or odd ball size thats close to 12") do you guys recomend? my friend has been telling me to get rid of my mtx subs and get some jl w3's. would that be a good match with this amp? what about some w'7? i dont really care about the price, if i really want to get a pair of subs, i'll find the money some how.
 

·
Registered
Joined
·
4,452 Posts
Discussion Starter #4
cooo...nevermind, i found out the problem. theres a "cap" kinda thing right in the middle of the sub that says "mtx audio". its just glued on there and the rattling is that it is starting to unglue, so its rattling when i hit base. going to try some crazy glue, see if that solves my problem.
 

·
Registered
Joined
·
4,908 Posts
As soon as you said Mtx I knew it was the dust caps. The 6000 and 8000 series always have that wrong with them.
 

·
Registered
Joined
·
4,908 Posts
Originally posted by HALO@Dec 24 2003, 10:00 PM
I had a set of 6000 series subs in my lowrider for 2 years. Never had one of those rattle loose. And I push my subs.Maybe he had a defective sub. Cause I had a pair of JBL subs that were straight up competition and one of the magnets rattled loose. And Best Buy would not honor the warranty. I just wrote it off and went to MTX
Its more common with the 8000 series.
 

·
Registered
Joined
·
4,452 Posts
Discussion Starter #11
i used some grey industrial grade gutter adhesive and they're holding up just fine now. the crazy sucked and came off right away lol. im going to face them in anyways, so you wont be able to see the subs. i put a layer on the inside, then sealed both of them off with about 1/2" all around the cap, just to make sure they dont come off again. i have also got to disagree that mtx suck. i have a pair of mtx 8000 and 81000d amp and this combination bumps! im not officially in the market for dynamat or maybe a bottle of foam to stop my trunk from rattling. it bumps!
 
1 - 11 of 11 Posts
Top