LayItLow.com Lowrider Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8,437 Posts
Discussion Starter #1
I have a caddy and my shit had gas mixing with tha oil so I took it in and the had to change my crankshaft bearings and I needed a new fuel pump regulator. When I started my car it was shaking so he told me I probably needed new spark plugs so i started driving off and when I left the parking lot and got and the main road my shit had little acceleration , I mean i had to press my foot all the way down and it still was slow as fuck.I opend the hood and noticed a whistling noise and it was coming from a small rubber tube and when i when pressed the tube in in a certain way it would stop whistling I dont know if that would stop it from accelerating but a couple dudes told me it would.. what do you guys think?
 

·
Registered
Joined
·
8,437 Posts
Discussion Starter #3
Thanks bro, so that little leak could cause my ride to get hardly any acceleration?
 

·
Registered
Joined
·
8,437 Posts
Discussion Starter #4
Originally posted by FloRida@Jan 7 2004, 07:58 PM
Thanks bro, so that little leak could cause my ride to get hardly any acceleration?
And could I mess something up if I drive it because I have to work all day tommorow?
 

·
Registered
Joined
·
12,068 Posts
just get some electical tape or duct tape and rap the shit out of it where the hose is leaking til it stops whistling. And hopefully u can get it to stop leaking enough to drive it temporarily.
 

·
Registered
Joined
·
1,474 Posts
you could probably repalce it for less than two bucks. just go to the parts store take it off in the parking lot take it inside and ask for a new vacume hose the same lenth and diameter. they charge by the foot and will cut it off the roll right there.

that is unless it has some wacky specical fitted end or something.
 

·
Registered
Joined
·
8,437 Posts
Discussion Starter #7
Is it ok to drive it with a leak like that. i wont be able to fix it until tommorow.
 

·
Registered
Joined
·
8,437 Posts
Discussion Starter #8
Ok I changed my spark plugs and fixed the hose .My shit has gotten worse, I mean I press my foot all the way to the floor and my shit dont really do much ,it will go but real real real slow.Today after driving it for like 20 minutes I go to my boys house and I smell and see smoke coming from my rear left tire ,wtf, it kind of smelled like plastic burning im not sure,but it did it again when i got home. Somebody please help me out. This mechanic told me that when the gas got mixed in with the oil it might of damaged the valves in the head and thats why its so fuckin powerless. When I floor the pedal it sounds like the engine is working hard as fuck but it barely moves dont get me wrong the car can still get up to 70 and more but it takes for ever.Like today I was turning into a parking lot and that shit took forever just to make a turn. help me please :(
 

·
Registered
Joined
·
4,772 Posts
try jackin car up and tryin to spin left rear tire. maybe brake problem?
 

·
Registered
Joined
·
1,478 Posts
Maybe that smell is coming from the exhaust. Maybe it's a sticker or you may have ran over a plastic bag.
 
1 - 13 of 13 Posts
Top