LayItLow.com Lowrider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
441 Posts
Discussion Starter #1
Has anyone had any problems with these? My cd player stopped working today, So I put another one in, which happens to be the same exact type, kenwood excelon x817, brand new, It played fine for a while and it went out to, all in the same day. All my car"s wiring and fuses are fine, one cd player is on warranty, the other one is not. What could be happening here? they just stopped working all of a sudden.
 

·
Registered
Joined
·
4,868 Posts
They have a notorious ability to OVERHEAT!!!!!!!!!!!!!!!!!

Believe me, I have had many problems with them. If its under warranty send that bitch in
 

·
Registered
Joined
·
1,478 Posts
I have had my Excelon for years and never had a problem.
 

·
Registered
Joined
·
35 Posts
I've had that same model for about 3-4 years now and the only problem I've ever had with it is the gears for the motorized face getting dirty and causing it to jam when it flips open or closed. A little air-in-a-can fixed that real quick though. Other than that every once in a while (when it's really cold outside) it won't read a CD. I guess the lens that reads the CD's fogs up so it can't see what's there. That problem corrects itself once the unit warms up a bit.
 

·
Registered
Joined
·
4,379 Posts
Yeah if you notice behind decks in a lot of cars its the heater ducting.... in some cars the heaters air can go right to the back of the deck, so heat could be an issue, it is getting cold out at least where I live.... got that heater on, so I wouldn't rule out heat....
 
1 - 8 of 8 Posts
Top