LayItLow.com Lowrider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
632 Posts
Discussion Starter · #1 ·
I remember reading a while ago about someone who had their pump mounting bolts penetrate the block and caused a leak right there. Is anyone able to find that thread, or does someone have insight to this? I've never had this happen to me, but I think it happened to someone I know....bad PH block machining?
 

·
Registered
Joined
·
9,793 Posts
are you sure its coming from there if the pumps are still in the car it take em out to check its not coming outa the bottom of the tank or from the motor side and running down
 

·
Registered
Joined
·
14,802 Posts
Originally posted by stevie d@Dec 18 2008, 08:33 PM~12469878
are you sure its coming from there if the pumps are still in the car it take em out to check its not coming outa the bottom of the tank or from the motor side and running down
that has my vote
 

·
Registered
Joined
·
1,502 Posts
might have been my post, turned out the return port had cracked through to the mounting bolt for the motor, but it looked like it was leaking from pump mounting bolt
was a prohopper block, installed a BMH block now and all sweet! :biggrin:
 

·
Registered
Joined
·
9,793 Posts
Originally posted by 68phatcad@Dec 18 2008, 09:20 PM~12470993
might have been my post, turned out the return port had cracked through to the mounting bolt for the motor, but it looked like it was leaking from pump mounting bolt
was a prohopper block, installed a BMH block now and all sweet!  :biggrin:
:thumbsup:
 

·
Premium Member
Joined
·
7,112 Posts
Originally posted by 68phatcad@Dec 18 2008, 10:20 PM~12470993
might have been my post, turned out the return port had cracked through to the mounting bolt for the motor, but it looked like it was leaking from pump mounting bolt
was a prohopper block, installed a BMH block now and all sweet!  :biggrin:
To the rescue :biggrin: .
 
1 - 7 of 7 Posts
Top