LayItLow.com Lowrider Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,478 Posts
Discussion Starter #1
I just purchased my first lowrider- an 85' Monte Carlo LS. It has 2 CCE pumps with 4 dumps. Whenever I raise the front, the front left starts to go down very slowly. There isn't a leak anywhere and the pump is full of oil and the batteries are charged. I think it is the check valve. If so, does anyone know how to replace it and what kind I should get? Where is the check valve? Help!




Last edited by peteypablo at Sep 10 2003, 01:45 PM
 

·
Registered
Joined
·
1,474 Posts
lay it low is a good place to find help. if you go to the hydro forum and do a search you will find a whole bunch of topics about this problem and how to fix it :cool: :cool:
 

·
Registered
Joined
·
13,248 Posts
do you have any leaks?

lock your car up, then close your slowdown valve the runs to that cylinder, if it still drops then your check valve most likely is at fault.

if is doesn't drop it could be your cylinder or mostly likely your dump. what kind of dumps do you have, sometimes your dumps stick, or don't close because of the spring or dirt not letting the valve close all the way.

do you have a 4 dump 2 pump setup? if so remove both dumps from the same pump that run to that cylinder and check them. if you see dirt and junk in them, mostly you dumps on your other pump will eventually have the same problem.

hope this helps :biggrin: ,

cc
 

·
Super Triple Double OG OG
Joined
·
22,640 Posts
most likwly, the problem is the dump stem orings....



pull off the dump cartridge,.
unscrew the stem,,,, replace he orings in there.....
 
1 - 5 of 5 Posts
Top