LayItLow.com Lowrider Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
9,196 Posts
Discussion Starter #1
I NOTICE MY OIL PRESSURE LIGHT KEEPS COMING ON BUT ONLY WHEN I PUSH ON THE GAS REAL HARD, N REV UP THE ENGINE BUT THEN IT SHUTS OFF IN LIKE 1 SEC, IT HAS NOT DONE IT FOR A WHILE BUT THEN IT STARTED LIKE 3 DAYS AGO, BUT IT ONLY LAST FOR LIKE 1 OR 2 SECS THEN TURNS OFF AND DOES NOT COME BACK ON FOR A WHILE.......IS IT THE OIL PRESSURE SENOR OR COULD IT BE OIL IS NOT FLOWING THREW THE ENGINE??? BUT THE CAR STILL RUNS FINE WHEN IT POPS ON FOR THAT SEC.

NEED HELP...THANKS!!!
 

·
Registered
Joined
·
20,447 Posts
Originally posted by DOUGHBOY 650@Aug 2 2005, 12:19 PM
I NOTICE MY OIL PRESSURE LIGHT KEEPS COMING ON BUT ONLY WHEN I PUSH ON THE GAS REAL HARD, N REV UP THE ENGINE BUT THEN IT SHUTS OFF IN LIKE 1 SEC, IT HAS NOT DONE IT FOR A WHILE BUT THEN IT STARTED LIKE 3 DAYS AGO, BUT IT ONLY LAST FOR LIKE 1 OR 2 SECS THEN TURNS OFF AND DOES NOT COME BACK ON FOR A WHILE.......IS IT THE OIL PRESSURE SENOR OR COULD IT BE OIL IS NOT FLOWING THREW THE ENGINE??? BUT THE CAR STILL RUNS FINE WHEN IT POPS ON FOR THAT SEC.

NEED HELP...THANKS!!!
[snapback]3528048[/snapback]​
Your engine's gonna blow. :cool: It seems like your oil pump is going out. What kinda vehicle?
 

·
Registered
Joined
·
9,196 Posts
Discussion Starter #7
I THINK I JUST MIGHT REPLACE IT AGAIN TO BE EVEN MORE SAFE...I DONT WANT MY ENGINE TO BLOW UP, BUT IF I DO IT, WUT ELSE COULD IT BE ANYONE???
 

·
Registered
Joined
·
3,918 Posts
Originally posted by DOUGHBOY 650@Aug 2 2005, 12:36 PM
I THINK I JUST MIGHT REPLACE IT AGAIN TO BE EVEN MORE SAFE...I DONT WANT MY ENGINE TO BLOW UP, BUT IF I DO IT, WUT ELSE COULD IT BE ANYONE???
[snapback]3528193[/snapback]​
If it's doin it off & on it could be a connection or a bad pump. Other than that I really don't have any other suggestions. I have the 3000 page service manual on the Fleetwoods. Let me know if you want me to check on it.
 

·
Registered
Joined
·
158 Posts
1st thing 1st, check oil level. Low oil can cause op light to come because of air in pump. If oil level is good, then check connection on op sensor. Get a mechanical op gauge hooked up if possible and see what it does. What weight of oil u using? Other possibility, stretch though, passage cloageage, but thats a stretch.
 

·
Registered
Joined
·
9,196 Posts
Discussion Starter #11
Originally posted by ogmonte77@Aug 2 2005, 01:03 PM
btw, why and when did u replace op?
[snapback]3528459[/snapback]​
like 3 months ago...but when i ask ppl everyone keeps sayin the sensor, cuz it keeps poppin off n on like a wire is touchin something...
 

·
Registered
Joined
·
573 Posts
I have the same problem with my 1993 fleetwood .just cuts of some times and oil pressure light comes on I put oil .car strata right back up and drives fine.
 

·
Registered
Joined
·
573 Posts
i have a 93 fleetwood oil pressure light come on and car shuts off ,starts right up after wards .it does that sometime when i turn the wheel all the way on and whenn coming to the top of a hill when stuck in traffic .would you no what this will be?
If it's doin it off & on it could be a connection or a bad pump. Other than that I really don't have any other suggestions. I have the 3000 page service manual on the Fleetwoods. Let me know if you want me to check on it.
 

·
Registered
Joined
·
573 Posts
Please check .
i have a 93 fleetwood oil pressure light come on and car shuts off ,starts right up after wards .it does that sometime when i turn the wheel all the way on and whenn coming to the top of a hill when stuck in traffic .would you no what this will be?
 

·
Moderator
Joined
·
18,723 Posts
it says in the instructions, use the fan speed to go through the different code sets, then push outside temp button to see the corresponding code with each set. go to 01 then push outside temp multiple times to see if you have any codes under 01 then 02 03 and 04
 
1 - 20 of 20 Posts
Top