LayItLow.com Lowrider Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
442 Posts
Discussion Starter #1
jus got a gf2 pumphead #11 put it on and jus over spins anyone know whats wrong
 

·
Registered
Joined
·
442 Posts
Discussion Starter #3
jus spins no fluid
 

·
Registered
Joined
·
442 Posts
Discussion Starter #7
thats what i thought got a new one and still the same shit
 

·
True-S Mike
Joined
·
251 Posts
did you tourque it right? if not, the fluid will just shoot out the side of the head
 

·
Registered
Joined
·
2,671 Posts
Yeah there should be 3 plugs in that head Make sure you remove ALL of them
 

·
Registered
Joined
·
9,656 Posts
are you sure you got enuff oil in it ...and or right size pressure seal?
 

·
True-S Mike
Joined
·
251 Posts
Originally posted by tufly@Aug 22 2005, 06:57 PM~3671745
i go 15 ft lbs.
i get in the low 20's. never had any luck with the teens....... always blew the seals out the side
 

·
Registered
Joined
·
10,737 Posts
Originally posted by KINGLOWNESS@Aug 22 2005, 06:40 PM~3671660
Yeah there should be 3 plugs in that head Make sure you remove ALL of them
either that or his check valves are backwards :0
 

·
True-S Mike
Joined
·
251 Posts
Originally posted by ExplicitDesignz@Aug 22 2005, 10:25 PM~3673198
When you guys are talking about torqueing (sp?) these, is this from the head TO the block? Or what?
yes, all 6 bolts needs tourqed with a ft pounds tourqe wrench. be sure all 6 are the same in a criss cross pattern
 

·
Registered
Joined
·
2,671 Posts
I Could be wrong but I have Built probably 500-800 Pumps If memory serves me it should be 22-26 lb Torque
 
1 - 19 of 19 Posts
Top