LayItLow.com Lowrider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
the rear is chipin when i drive any sugestions on how to cure this prob im runin about 5 turns of a blue coil i got used not sure of the tonage i think its about a 2 ton ,, 4 pumps 10 batt in the trunk do u think i need to up the tonnage to like 4 ton? will that stop the chippin ?or do i need a softer spring ??? pls help any sugestions thanks
 

·
Registered
Joined
·
2,097 Posts
With the info that you've given, it sounds like you need a couple of shocks back there.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
thanks for the imput looking for another alternitive :uh:



Last edited by phat2600 at Oct 9 2003, 02:57 PM
 

·
Registered
Joined
·
2,097 Posts
Originally posted by phat2600@Oct 9 2003, 04:57 PM
thanks for the imput looking for another alternitive :uh:
Sorry, I wasn't being a smart ass, I thought that was all you needed.
But to go in depth, your spring specs are reversed. You probably have a harder spring (the 4-ton) installed now. If you were to replace it with a 2-ton, it definitely wouldn't be chippin' in the rear with 10 batteries. Besides shocks (which you seem to not be a big fan of) you would want to put in a lower rated spring than whatever you're running to smooth out the ride. Other than that, I would suggest accumulators.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #5
lower spring thats what i wanted to hear thanks for the tip im gona put 5 turns of the stock fronts in there and see how it is ,... btw i wasnt thinking u were a smart ass.. just dont wana deal w, shocks thanks for the info, later ;)
 

·
Registered
Joined
·
50 Posts
Discussion Starter #7
bob thanks for the imput guess im gona have to try it both ways .. just sucks crawlin under that cadi since i dont have a lift ;) but then again its worth it thanks again for the info BTW i gota get some pics of my 74 caddi up here so u can ck it out Tony
 
1 - 7 of 7 Posts
Top