LayItLow.com Lowrider Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
i bought a 94 nissan wit draulics and the motor burnt on the one pump all 4 lines were runnin off of. I bought a new chrome pro hopper pump wit 2 dumps and chrome cylinders, 8" and 10". It was setup where the back had to pick up first then the front. I got 4 batteries hooked up and it just struggles to pick up the back and sometimes picks up the front. It was all done half ass before and now it isn't workin. I got the one pump runnin all 4 cylinders off of pro hopper.com.Any help would be appreciated. This is my only ride.
 

·
Registered
Joined
·
1,474 Posts
this may sound dumb, but are the batteries charged? when was the last time they were charged?you have them ran in series, not parrael, right? on your car the back lifts up before the front because it is lighter.the only reason for the front to lift up first is if you have a lot of weight in the back. was there people in the back seat when it did that?you replaced the pump-- when you replaced the plumping it is possible the a check valve was put back in backwards.

if it was me i would buy a new motor for that pump you replaced and make it a two pump set up!
 

·
Registered
Joined
·
1,059 Posts
Originally posted by juicednissan@Jul 21 2003, 08:44 PM
i bought a 94 nissan wit draulics and the motor burnt on the one pump all 4 lines were runnin off of. I bought a new chrome pro hopper pump wit 2 dumps and chrome cylinders, 8" and 10". It was setup where the back had to pick up first then the front. I got 4 batteries hooked up and it just struggles to pick up the back and sometimes picks up the front. It was all done half ass before and now it isn't workin. I got the one pump runnin all 4 cylinders off of pro hopper.com.Any help would be appreciated. This is my only ride.
It would be more effecient with a 2 pump set-up! Believe me!
 
1 - 4 of 4 Posts
Top