LayItLow.com Lowrider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,549 Posts
Discussion Starter #1
the back right corner on my monte is always going down nothing is loose and theres no leak of oil shown so i closed my slow down and it still does it
does anyone know what it could be also everything on my pump is less than a month old
 

·
Registered
Joined
·
14,802 Posts
Originally posted by dropped81@Dec 19 2008, 01:31 AM~12473014
the back right corner on my monte is always going down nothing is loose and theres no leak of oil shown so i closed my slow down and it still does it
does anyone know what it could be also everything on my pump is less than a month old
if u closed the slowdown and still does it. you have a check valve goin bad. and u better take care of it asap before it doesnt hold any pressure at all
 

·
Registered
Joined
·
3,549 Posts
Discussion Starter #5
Originally posted by KINGFISH_CUSTOMS@Dec 19 2008, 10:13 AM~12475529
if u closed the slowdown and still does it.  you have a check valve goin bad.  and u better take care of it asap before it doesnt hold any pressure at all
alrite thanks
 

·
Registered
Joined
·
14,802 Posts
Originally posted by dropped81@Dec 19 2008, 03:04 PM~12476944
alrite thanks
no problem. and if u have those lil 3/8 BB check valves id get a better one. those usually go out within a year or so...
 

·
Registered
Joined
·
3,549 Posts
Discussion Starter #7
Originally posted by KINGFISH_CUSTOMS@Dec 19 2008, 02:12 PM~12477504
no problem.  and if u have those lil 3/8 BB check valves id get a better one.  those usually go out within a year or so...
this is a pic of my setup the left pump is for the back the rite pump is for the front

 
1 - 8 of 8 Posts
Top