LayItLow.com Lowrider Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4,710 Posts
Discussion Starter #1
I'm workin on my 82 Coupe DeVille. I just replaced my factory deck w/ a Power Acoustik 7" Touchscreen Flip Out (PTID-8960). I used a wiring harness to hook it into the factory wiring. The deck's says 50x4 Peak & 17x4 RMS.
I also replaced the dash speakers w/ Power Acoustik 2way 4x6's. the rear deck speakers are the factory 4x10's b/c I haven't got to them yet.
My problem is I can barely hear my speakers. Out of 30 on my volume, I have to turn it up to 15 to mildly hear it, 20 to hear it mid-low & 25 to hear it ok. This just don't seem right. I don't wanna buy a amp b/c the 4x6's don't hold much power as it is...

Anyone got any ideas? Thanks...
 

·
Registered
Joined
·
3,196 Posts
Originally posted by dreday@Oct 1 2007, 09:53 AM~8906051
I'm workin on my 82 Coupe DeVille. I just replaced my factory deck w/ a Power Acoustik 7" Touchscreen Flip Out (PTID-8960). I used a wiring harness to hook it into the factory wiring. The deck's says 50x4 Peak & 17x4 RMS.
I also replaced the dash speakers w/ Power Acoustik 2way 4x6's. the rear deck speakers are the factory 4x10's b/c I haven't got to them yet.
My problem is I can barely hear my speakers. Out of 30 on my volume, I have to turn it up to 15 to mildly hear it, 20 to hear it mid-low & 25 to hear it ok. This just don't seem right. I don't wanna buy a amp b/c  the 4x6's don't hold much power as it is...

Anyone got any ideas? Thanks...
get a panasonic :biggrin:

seriously though, have you gone through your settings? If you have an eq on the HU, you might have to set it, or maybe select one of the presets (i.e. rock, jazz, flat (probably what your on), etc)...

When i first started out, i had a sony HU, and i had to turn it up all the way just to hear out of the speakers. after shifting through the different menu's and settings, and playing around, i realized that i just had to set it.
 

·
Registered
Joined
·
7,717 Posts
does it have a loud mode, that usually boosts the fuckin things


and some headunits play extra low, i had one that went to 30 before you could hear it decent and 63 was fulll volume
 

·
Registered
Joined
·
525 Posts
some also have volume control too. my JVC has a volume control up to 10. it basically just boosts it louder so for example if your volume is at 1 and the VC is at 2, your volume should sound like its at 3, do you have anything like that?
 

·
Registered
Joined
·
1,662 Posts
my jvc was the same way then i found it was the amp=lo,mid,hi setting.at first the highet it would go was 30 but after messing with that setting it now goes up to 50
 

·
Registered
Joined
·
4,710 Posts
Discussion Starter #10
Originally posted by silver64@Oct 1 2007, 12:51 PM~8907725
does it have a loud mode, that usually boosts the fuckin things
and some headunits play extra low, i had one that went to 30 before you could hear it decent and 63 was fulll volume
This sounds like my shit..................
 

·
Registered
Joined
·
4,710 Posts
Discussion Starter #11
Originally posted by kannabis@Oct 1 2007, 01:58 PM~8908252
Does the factory system have any built in amp type setup?
An open ground is what comes to my mind....
I thought about that too. To the best of my knowledge, no.

Too, usually a factory amp makes the sound jump up really fast...
 

·
Registered
Joined
·
4,710 Posts
Discussion Starter #12
Talked to a service tech today at Power Acoustik, after about 20x's of tryin to get through.
He said the deck isn't meant to be loud. Its meant to get the signals to the amps & let the amps do the loudness part...
Kinda a relief I guess but sucks in a way too. Oh well...

Thanks everyone for the tips. I greatly appreciate all the responses.
 
1 - 12 of 12 Posts
Top