LayItLow.com Lowrider Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am new to this airbag thing and I just purchased a 1998 Mustang GT that has an airbag system on it. What I know is that each corner of the car has a Blitzluft N212 Valve and a Blitzluft dump valve (is that right?). One of the Valves and Dump valves on the front were damaged and did not allow the front to work at all. I "t'd" the lines off and run them into the remaining valve and dump valve. The rear of the car shoots up FAST, but the front takes FOREVER to air up. I can't imagine running the front off of only one valve would make it as slow as it is. Could there be any other issues? What should I check for? Thank you in advance for your patience with me.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
1/2" 280 psi valves. 2 Viair 380C compressors (200 psi), 3/8" lines. 200 psi pressure switches and a 5 gallon tank. I understand that the front will be slower because of weight..but we are talking ridiculously slow. Probably 30-45 seconds before it gets to ride height. Thanks again for the help.
 

·
Registered
Joined
·
11,655 Posts
Yeah thats retarded slowwwww. Somethings goin on.I used to have 3/8" valves line t'd off in my cutlass w/ a V8 an at 200 psi it was pretty snappy.

Make sure the line isn't kinked anywhere.Then i'd start on the valves.See if there sticking or have crap in them.

Most the time if you have a smaller bag in the front it will take more psi to lift.But 200 should lift it w/ no problem.

What kinda bags are in the front?
 
1 - 5 of 5 Posts
Top