LayItLow.com Lowrider Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
512 Posts
Discussion Starter #1
LAST NIGHT I WENT TO CHARGE THE BATTERIES FOR THE FIRST TIME SINCE I GOT MY CAR AND SINCE I HAVE A MULTPLE BATTERY CHARGER THAT HAS A DIAL THAT SAY 12-24-36-48-60-72-84-96, I FIGURED I COULD CHARGE 8 AT ON TIME. SO I AM POSSITIVE I HOOKED THEM UP RIGHT AND I DISCONNECTED THE GROUND SET THE CONTROL KNOB (WHICH READS 2-4-6-8) TO 2 BECAUSE I FIGURED THAT, THAT WAS THE AMPS. PLUGED IT IN AND THE SWITCHED IT TO ON. IT MADE A SCARY NOISE AND SMOKE STARTED TO POUR OUT. SO THEN I TRIED TO DO JUST ONE BANK AT A TIME AND SET IT TO 36 (EVEN THO ITS 48, JUST WANTED TO PLAY IT SAFE) AND 2 AMPS AND THE AMP METER SHOT UP TO WAY PAST 8 AND IT MADE THE NOISE BUT I HAD MY FINGER ON THE SWITCH AND SHUT IT OFF RIGHT AWAY. AFTER THAT I JUST PUT IT AWAY AND SAID NO CHARGING BATTERIES TONIGHT. I HAVNT CHECKED THE FUSES BUT DOES ANYONE HAVE ANY IDEA WHAT HAPPENED.

I HAVE 8 BATTERIES 2 BANKS. THE BANKS ARE HOOKED UP TO ONE ANOTHER
COULD THAT BE THE REASON. IM TAKING PICTURES WHEN I GET HOME.
 

·
Registered
Joined
·
3,918 Posts
I can't answer your question cause I've never used a multi-battery charger. The only thing I can think of is if you still have the quick disconnect hooked up or if maybe you have to unhook the batteries from series and re-wire them parallel (although I'm pretty sure I'm wrong since the charger states "12/24/36 etc".

Is that your ride in the avatar? If so I would like to see some pics. From I see it looks clean.
 

·
Registered
Joined
·
33 Posts
2 amps is a good setting it will take a little longer but is better for the batteries. as for the mess up one thing i have seen happen is if your batteries are real low the read a lot less then the 96 so you might have to click it down one to 84 for a little while few hours then click it to the 96 once the charger reads higher. what happens is the chrager does not know you have 8 batteries it only reads the out put of the batteries and dose not adjst to dead batteries. send me a pic of the charger and the way you have them hooked up then i can give you better advice. if it is burnt out let me know we have a guy here that fixes them.

good luck
Freddy

Low Joes




Check us out My Webpage
 

·
Registered
Joined
·
1,968 Posts
Is there any possible way that the leads coming out of the charger got reversed? just something to think about.
 

·
Registered
Joined
·
7,112 Posts
Originally posted by BIGCRAIG@Jul 29 2005, 02:34 PM
LAST NIGHT I WENT TO CHARGE THE BATTERIES FOR THE FIRST TIME SINCE I GOT MY CAR AND SINCE I HAVE A MULTPLE BATTERY CHARGER THAT HAS A DIAL THAT SAY 12-24-36-48-60-72-84-96, I FIGURED I COULD CHARGE 8 AT ON TIME. SO I AM POSSITIVE I HOOKED THEM UP RIGHT AND I DISCONNECTED THE GROUND SET THE CONTROL KNOB (WHICH READS 2-4-6-8) TO 2 BECAUSE I FIGURED THAT, THAT WAS THE AMPS. PLUGED IT IN AND THE SWITCHED IT TO ON. IT MADE A SCARY NOISE AND SMOKE STARTED TO  POUR OUT. SO THEN I TRIED TO DO JUST ONE BANK AT A TIME AND SET IT TO 36 (EVEN THO ITS 48, JUST WANTED TO PLAY IT SAFE) AND 2 AMPS AND THE AMP METER SHOT UP TO WAY PAST 8 AND IT MADE THE NOISE BUT I HAD MY FINGER ON THE SWITCH AND SHUT IT OFF RIGHT AWAY. AFTER THAT I JUST PUT IT AWAY AND SAID NO CHARGING BATTERIES TONIGHT. I HAVNT CHECKED THE FUSES BUT DOES ANYONE HAVE ANY IDEA WHAT HAPPENED.

I HAVE 8 BATTERIES 2 BANKS. THE BANKS ARE HOOKED UP TO ONE ANOTHER
COULD THAT BE THE REASON. IM TAKING PICTURES WHEN I GET HOME.
[snapback]3505565[/snapback]​
DO U HAVE ''2'' BANK @ 48 VOLTS ,AND WERE TRYIN' TO CHARGE @ 96 ??????

IT SHOULD HAVE BLOW THAT FUSE RITE AWAY

IF THE FUSE AINT BLOWN...IT COULD WRECK THE RECTIFIER/BRIDGE
 

·
Registered
Joined
·
512 Posts
Discussion Starter #6
Originally posted by Lac of Respect@Jul 29 2005, 04:37 PM
Is that your ride in the avatar?  If so I would like to see some pics.  From I see it looks clean.
[snapback]3505586[/snapback]​
ya thats my car ill get some pics today.
im going to try one bank at a time and just play around with it. my ground was dissconnected. if all fails i have a single battery charger and ill have to do it front folk way. thanks for the help guys
 
1 - 6 of 6 Posts
Top