LayItLow.com Lowrider Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter · #1 ·
hey guys i was gettin some oil in my motor so i took the motor off and cleaned it out. The pump has no markings on it what so ever, besides the block the block says CCE. I took the pumphead off to get to the seal and got the old seal out and everything. now i need to replace the seal and i dont know which seal to get because i dont know what pumphead i got. there are no marking on the pumphead besides these numbers "4731" if you guys could help me out i would truely be thankful. thanks justin
 
G

·
Originally posted by EL_PASO@Oct 1 2006, 10:32 PM~6286133
get the other ones hommie cause I boght those blowproof ones and it wouldnt fit
that because you had the smaller shaft odd ball pump heads.

the blowproofs work perfect.
 

·
Registered
Joined
·
7,749 Posts
Originally posted by classic kustoms@Oct 2 2006, 02:23 AM~6286656
that because you had the smaller shaft odd ball pump heads.

the blowproofs work perfect.
i know but the hommie whos asking the q sounds like he got the same as me
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #8 ·
alright thanks for everything. Would anyone know wut size the pumphead it is with those numbers on it (4731)? thanks justin
 
G

·
Originally posted by showlow@Oct 2 2006, 06:14 PM~6291453
alright thanks for everything.  Would anyone know wut size the pumphead it is with those numbers on it (4731)? thanks justin

tell us the measurement of the shaft.
 
1 - 15 of 15 Posts
Top