LayItLow.com Lowrider Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5,077 Posts
is the plastic on the fuse melting or just the metal part. I have had the metal begin to melt and i think it was because there were alot of amps running through it but not quite enough to blow it
 

·
Registered
Joined
·
304 Posts
Im not really an electronic expert but what size is your ground and power wire?
 

·
Registered
Joined
·
3,455 Posts
is their a fuse in the power wire before reaches amp..its reactiuon?

are you useing a lighter to light it ..lol?
 

·
Registered
Joined
·
867 Posts
you may have a short in your amp or your ground may not be the best they also recommend not having a ground more then 14in long and also having a inline fuse with in 18 in of your battery if all of these are right then your amp is FUCKED :0
 

·
Registered
Joined
·
4,080 Posts
Discussion Starter #10
my grounds not so good i know that been meaning to fix it

but everything else is correct

my ground isnt over a foot long and my fuse is about 6 inches from battery terminal
 

·
Registered
Joined
·
12,350 Posts
Check to see it your fuses sit tight in the fuse slot... If they are loose in there they will vibrate around with the bass and get really hot and melt... Just an idea... :cool:
 

·
Registered
Joined
·
4,080 Posts
Discussion Starter #12
Originally posted by Naughty T@Oct 4 2003, 07:36 AM
Check to see it your fuses sit tight in the fuse slot... If they are loose in there they will vibrate around with the bass and get really hot and melt... Just an idea... :cool:
u know i think that may be the problem every once in awhile i got to go back there and push it back in
 
1 - 12 of 12 Posts
Top