LayItLow.com Lowrider Forums banner
1 - 20 of 41 Posts

· Registered
Joined
·
2,544 Posts
Discussion Starter · #1 ·
sup fellas, man i have been having problems for quite a while now and i cant figure out why, man it all started hen i was hittin switches and i melted the termnals and part of my batteries and it smelled like complete shit in my trunk, so i got many reponces on why it would do that, so i replaced my batts, and so im hitting switches (and i have a switch box) and looking into my trunk and outta one of the holes for the scrws that the armtures of the motor is mounted to i see smoke as i am and right after im hiting the switch, and im like oh fuck i burnt a motor, so i called up reds hydros and they told me it is because imy batts werent over 900 ccas but just to be sure i pulled off my motor , and like 1/8th to 1/4 pint of hydro fluid and its all black and i realized thats what it was. so i cleaned it all out cleaned up the motor popped it back in andi hit swittches for a little bit and the batt terminals are hot as fuck, it burnt my hand just from touching them please hep me :banghead: :banghead: :barf: :worship: :tears:
 

· Registered
Joined
·
3,585 Posts
use 0 gauge wire and how manny batts are u using and how do you have them wired up ?
 

· Registered
Joined
·
763 Posts
batts suck to much load need better batts bigger wires
 

· Member # 1,077
Joined
·
22,061 Posts
get some groupe 31's. are you using car batts? theyre not meant for that shit really....
 

· Member # 1,077
Joined
·
22,061 Posts
mabye your ground is bad.
 

· Member # 1,077
Joined
·
22,061 Posts
lets see some pics of the whip and the setup
 

· Registered
Joined
·
2,544 Posts
Discussion Starter · #16 ·
Originally posted by pimpoldscutlass81@Sep 14 2005, 07:20 PM~3817537
lets see some pics of the whip and the setup
i dont have a digital camer but its just a basic 2 pump 4 battery setup, do u think bad ground could make the batts get hella hot tho??
 

· Member # 1,077
Joined
·
22,061 Posts
yes
 

· Registered
Joined
·
1,001 Posts
He needs a new ground I know that fore sure from the first time I looked at it, But I say its prolly you need those 31's and thicker cable, I know I need thicker cable. That is soon to come. Hey Evan you have an extra quickdisconnect from one of those kits you bought?
 

· Registered
Joined
·
1,883 Posts
Originally posted by BigLinc@Sep 14 2005, 11:28 PM~3818697
i never use less then 1/0 no matter the number of batts
:thumbsup:
 
1 - 20 of 41 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top