LayItLow.com Lowrider Forums banner
1 - 8 of 8 Posts

·
Super Smasher
Joined
·
3,948 Posts
Discussion Starter · #1 ·
I have a 83 coupe with the 350 swap.....I was driving it...everything is fine oil guage reads 30 pounds car is warmed up at running temp..... then the stop engine low oil pressure light comes on WTF??? I stop check the oil it looks fine, I have to drive home so I do the gauge keeps reading 30-40 pounds what should I do
 

·
Triple OG
Joined
·
11,047 Posts
probally a bad oil pressure switch.


change it and see what happens. They are like 4 bucks at autozone.


you don't want to play with oil pressure dude.

What if the guage is bad and its giving you a bad reading? That is why the switch goes off.
 

·
Super Smasher
Joined
·
3,948 Posts
Discussion Starter · #6 ·
its a after market guage engine sounds fine oil level is fine?
 

·
Registered
Joined
·
3,195 Posts
Take the bulb out of the dash. Did you use oil pressure swich from the 4.1? If so use one for a 305, on the gauge my 4.1 read 60 lbs :confused:,but my Chevy runs between 30 and 45 lbs. The Caddy engine may have a higher set switch.
 

·
Triple OG
Joined
·
11,047 Posts
Originally posted by Dylante63@Sep 16 2005, 02:18 PM~3829055
its a after market guage engine sounds fine oil level is fine?


yea, but if the dummy light is going off somethings up.


You have 2 things. An oil pressure switch and a sensor. the switch is the dummy light. the sensor is the gauge. one is either bad or not connected right.


I would bet its the switch.


Check them out on the engine. the gauge should be on top by the distributer and the switch should be down by where the oil filter is...


there is a wire that comes from them both and goes to the wire harness.

check connections and then if its good then replace the switch first.

like I said, you don't want to play with oil pressure man. do it or you might find yourself replacing way more than a switch or sensor.
 
1 - 8 of 8 Posts
Top