LayItLow.com Lowrider Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,498 Posts
Discussion Starter #1
Hey what's up you hydraulic pros!?

Question for you...

Over the last couple weeks, I've noticed that once in a while, I'll tap up my front end and it will "stick" and the car locks all the way up... Almost instantly, I'll hit that switch down (dump it down) and it will stop everything. Then it will be okay. It's a pretty new 2-pump setup. I've had it since July.

All eight batteries are fully charged.

Do you think that I have a switch problem or a solenoid problem? Or do you think it's something else?

Thanks, in advance, for your help and input! :cool:
 

·
Registered
Joined
·
3,540 Posts
its a switch problem. sounds like you may have the cheaper switches. if you dont have carlings (made in mexico) get them.
 

·
Registered
Joined
·
14,802 Posts
Originally posted by El Volo@Dec 12 2008, 04:08 PM~12413781
Hey what's up you hydraulic pros!?

Question for you...

Over the last couple weeks, I've noticed that once in a while, I'll tap up my front end and it will "stick" and the car locks all the way up... Almost instantly, I'll hit that switch down (dump it down) and it will stop everything.  Then it will be okay.  It's a pretty new 2-pump setup.  I've had it since July.

All eight batteries are fully charged. 

Do you think that I have a switch problem or a solenoid problem?  Or do you think it's something else?

Thanks, in advance, for your help and input!  :cool:
sounds like ur running cheap ass switches. you might want to flip the dump and pump power wires on that switch so that it atleast sticks in the dump position instead of the hot positions. cheaper to replace a dump then to bend or break anything. or replace a motor, pumphead or rebuild the pumphead. get u some carling switches
 

·
Registered
Joined
·
3,498 Posts
Discussion Starter #6
Thanks guys for your help... I really appreciate your time and advice.

I'll try getting those carling switches. ;) :cool:
 

·
Registered
Joined
·
3,206 Posts
just went threw that
i thought it was the switch but it was the solenoind block it stayed open after the third time
also make sutre u not running more then 24v to the switchs
 

·
Registered
Joined
·
1,255 Posts
x5 switch
 
1 - 8 of 8 Posts
Top