LayItLow.com Lowrider Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
Ok well i've beenusing one of pumps to test out my install,...it is just a Red's competition pump with 2 delta dumps...my qestion is...

When i juiced up the back, it slowly leaked down over night about 5 inchs,...when i swapped the pump over to test the front,...it leaked al the way down within like 30 minutes....but i don't see ny fluid anywhere leaking out???
ouls it be perhaps that this one pump doesn't have a slow down valve on it?? I don't even know what a slow down does,...but this is my only pump that didn't have one...any help ???
 

·
Registered
Joined
·
4,908 Posts
Here is what you need to do. Close the slowdown on the pump that has one and see if it still leaks down. If so then its your checks. They might be bad or just have something keeping them from closing all the way. If it stays up then more than likely its your dumps.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #6
well i've decided to run a 3 pump setup, i think the motor on my fourth pump is shot, becuase when i throw it juice it doesn't do anything, it spun once when i hooked it up, then that was it,...

i'm gonna take my Roadster dumps, and slowdown off the busted pump, and put them on the good pump, then i'll see i guess

Appreciate the info guys, any more would be grea if anyone can think of anything different
 

·
Registered
Joined
·
410 Posts
Well, since you have a RED's pump, I would suggest calling the people who built it and work on them every day.......





We will help you out in any way we can. Just ask for tech support! And tell us that you saw it on LAYITLOW.com



Last edited by redsproseries at Oct 14 2003, 12:08 PM
 
1 - 7 of 7 Posts
Top