LayItLow.com Lowrider Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
Ok here is my problem...

My pump is pushing,...i took the dump and everything and hit it, shot oil about 1 foot in the air, but when its all hooked up, the motor just turns, but nothing comes out. even when i discnnected the returnhose to see if the dump was stuck open, still nothing. it like the fluid stops in the dump and doesn't go anywhere after that.

Next i took that dump off my 3rd pump, and added it to my 2nd pump,...no that pump doesn't work...i thought atleast one side would juice if one dump was bad....i'm stuck???
They are Roadtser dumps if that help,...they ain't squre though, they look like deltas
PLEASE HELP!!!
 

·
Registered
Joined
·
8,700 Posts
Originally posted by Schimel750@Oct 19 2003, 10:44 PM
Ok here is my problem...

My pump is pushing,...i took the dump and everything and hit it, shot oil about 1 foot in the air, but when its all hooked up, the motor just turns, but nothing comes out. even when i discnnected the returnhose to see if the dump was stuck open, still nothing. it like the fluid stops in the dump and doesn't go anywhere after that.

Next i took that dump off my 3rd pump, and added it to my 2nd pump,...no that pump doesn't work...i thought atleast one side would juice if one dump was bad....i'm stuck???
They are Roadtser dumps if that help,...they ain't squre though, they look like deltas
PLEASE HELP!!!
Shot oil about one foot in the air? If I undo a hose I know for a fact I can shoot oil accross the street into the neighbors front yard. Maybe you have a bad motor? swap your motors around once and see if your problem is fixed.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #3
no i'm saying it shot out straight up out o the block,...from the pressure hole,...thee were no fittings, dumps nothing, tank, motor, block...

The thing is that NEITHER pump work when i add that dump, why is hat? the pumps won't work with the Roadtser, i have some old Deltas that don't dump out, but the pumps will lift hard with them on there!

Is there anything i can do to get it to work, why is it not working,...or hould i just buy either new dumps or new guts for the deltas,...i don't dance hop or anything like that, just tryin to 3 wheel, the Deltas work pretty good for me..
Who sells Roadtser suff??
 

·
Registered
Joined
·
10,888 Posts
you say you took the return hose off.......and there was no oil right?????????


if there was no oil it IS the check valve is in the wong way OR you don't have the check valve in the right position........

if you can take pics........or tell us more about how you put the check valves in etc.........
 

·
Registered
Joined
·
310 Posts
Discussion Starter #6
Umm,...check valve? i don't even think my sehas those, or iono, see that the one thing i havn't learned much about, check valves,...could you send me a picture of a pump plumbed with a check valve on it, i know kinda what they look like thatsd why i say i don't think i have them, but i sorta new thats why i ask you experts ya know lol...

i try and get a picture tomorrow and post, maybe you guys can figure it out
 

·
Registered
Joined
·
310 Posts
Discussion Starter #7
 

·
Registered
Joined
·
310 Posts
Discussion Starter #8






 

·
Registered
Joined
·
310 Posts
Discussion Starter #9
sorry, posted the other picture twice, heres a different view,...what do you think? do i have a check valve,...ignore the lose hose, ad the dump on the tank side of the pump isn't plumbed right i know, but i didn't re do it, i had it plumbed right the first time when it didn't work

 

·
Registered
Joined
·
9,656 Posts
yeah the checks are right there off the pressure port and it's tee'ed you have one on each side of that tee take em out and turn them around ..

and dont forget new teflon



Last edited by ice64berg at Oct 21 2003, 06:37 AM
 

·
Registered
Joined
·
1,019 Posts


two checks on each pump.
when you look in the end of them you will see a ball..........poke the ball with something clean. one end it will move the other end it wont move. the end you poked it from that allowed it to move goes into the tee...............
[and there should be a flow arrow on it to help ]
 

·
Registered
Joined
·
310 Posts
Discussion Starter #12
ok so justtake the check valves off, turn them around? if one of the chcks is backward, and the other is ok, would that keep the whole pump from working?

the end that i poke and the ball moves, sould go INTO the T, or INTO the dump?
 

·
Registered
Joined
·
8,700 Posts
Originally posted by Schimel750@Oct 21 2003, 06:34 AM
ok so justtake the check valves off, turn them around? if one of the chcks is backward, and the other is ok, would that keep the whole pump from working?

the end that i poke and the ball moves, sould go INTO the T, or INTO the dump?
Well if just one is backwards then only one side will lift, if they are both backwards then it wont lift at all.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #14
See thats what i was figuring,...the left pump worked with one dump on it, but the right pump didn't, the motor just spun, so i took the dump off the right pump and plumbed it into he left pump for a 3 pump setup just to drive on, now the left pump is doing the same thing as the right one did....but i never removed the checks, i left them attached to the dumps....thats whats blowng my mind
 
1 - 14 of 14 Posts
Top