LayItLow.com Lowrider Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Ive had pumps in the bed of my S 10 for a year now without a tonneau.They are out there in the weather.It rains alot here but ive never had a problem.This weekend my back pump stopped working so I pulled it apart until i fount the prob. My motor was half full of water.My question is how can I stop that without covering my bed. And can the motor be rebuilt or is it better to get a new one? Who makes the best motor. Its a Black Magic setup if that matters.Thanks
 

·
Registered
Joined
·
358 Posts
Originally posted by stinkypinky@Sep 11 2005, 10:55 AM~3793086
Ive had pumps in the bed of my S 10 for a year now without a tonneau.They are out there in the weather.It rains alot here but ive never had a problem.This weekend my back pump stopped working so I pulled it apart until i fount the prob. My motor was half full of water.My question is how can I stop that without covering my bed. And can the motor be rebuilt or is it better to get a new one? Who makes the best motor. Its a Black Magic setup if that matters.Thanks

make sure you're running non-vented end caps.
 

·
Registered
Joined
·
1,883 Posts
Originally posted by juiced@Sep 11 2005, 01:13 PM~3793408
make sure you're running non-vented end caps.
thats how i had my s-10. the pumps were mounted under the bed, but when i was drivin in the rain, the pumps got saterated.. i never had any problems and the motors were prestolite mue-6113 non vented.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top