LayItLow.com Lowrider Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
6,121 Posts
Discussion Starter #1
This is weird. Recently my windows get really fogged up when the heater goes on, nothing will avoid it...nothing will clear it. I can also smell antifreeze. The car has not overheated, the dummy lights do not turn on.

This morning I was on the freeway and turned the heater on, immediatly my windows began to fog up and I could see/taste a water mist coming from my heater. Also no heat or air condi. coming from vents or defrost, all coming only from floor vent.

I was kind of thinking this could be a heater core issue but have noticed no other symptoms. I would like to take the route of least resistance when dumping money into this one so if anyone has ideas please let me know.
:thumbsup:
 

·
Member # 1,077
Joined
·
22,641 Posts
thats weird, that just happened to me the other day as well... i just assumed it was the heater core...
 

·
Registered
Joined
·
16,329 Posts
Originally posted by DIRTYSANCHEZ423@Feb 8 2010, 06:47 PM~16552291
HEATER CORE FA SHO
x2 or 3!!! :biggrin: Dat shit happened to me a couple years ago...
 

·
Registered
Joined
·
6,121 Posts
Discussion Starter #5
Originally posted by DIRTYSANCHEZ423@Feb 8 2010, 04:47 PM~16552291
HEATER CORE FA SHO
:angry: :yessad:


Didnt want to bother you asking, I know you your a mechanic cause I seen some of your work...



:biggrin: :biggrin:
 

·
Member # 1,077
Joined
·
22,641 Posts
fucking bullshit the fucking shit had to die on me when its 20 degrees outside :mad:
 

·
Registered
Joined
·
75 Posts
Originally posted by Cali-Stylz@Feb 8 2010, 06:32 PM~16552709
:angry:  :yessad: 
Didnt want to bother you asking, I know you your a mechanic cause I seen some of your work...



:biggrin:  :biggrin:

:thumbsup: :thumbsup: :nono: :biggrin:
 

·
Registered
Joined
·
512 Posts
ya sounds like a heater core and those symptoms arent just limited to 1 vehicle my 97 taurus is doin the same shit but after a few seconds the fog goes away
 

·
Registered
Joined
·
113 Posts
definitley the heater core, had an 83 coupe and even with it off still smelled like antifreeze and the fog wouldnt stop, shit sucked, car got totaled before i ever fixed it, so not sure how easy it is to change out
 

·
Registered
Joined
·
113 Posts
Originally posted by Cali-Stylz@Feb 8 2010, 06:32 PM~16552709
:angry:  :yessad: 
Didnt want to bother you asking, I know you your a mechanic cause I seen some of your work...



:biggrin:  :biggrin:
thats the best lookin jackstands ive ever seen!!! they sell those at harbor freight or sears??
 

·
Registered
Joined
·
24,862 Posts
Originally posted by coolbeans@Feb 17 2010, 03:46 PM~16641233
thats the best lookin jackstands ive ever seen!!! they sell those at harbor freight or sears??
:uh: :uh: :twak: dumbass










































snap on or a mac truck only.. top'a the line shit, foo
 

·
Registered
Joined
·
113 Posts
Originally posted by biggeazy-e@Feb 17 2010, 03:58 PM~16642402
:uh:  :uh: :twak: dumbass
snap on or a mac truck only.. top'a the line shit, foo
:biggrin: good lookin out bro, have to flag down one of their trucks for that shit
 

·
Registered
Joined
·
6,121 Posts
Discussion Starter #15
Had the heater core replaced a couple weeks ago. Problem solved :biggrin: Guess I should take the disco ball and strobe light out now. :(
 

·
Registered
Joined
·
1,697 Posts
Originally posted by Cali-Stylz@Feb 8 2010, 05:32 PM~16552709
:angry:  :yessad: 
Didnt want to bother you asking, I know you your a mechanic cause I seen some of your work...



:biggrin:  :biggrin:
this picture has to be from mexico,oh btw its your heater core,no coolant on the floor yet?
 
1 - 17 of 17 Posts
Top