LayItLow.com Lowrider Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
DOES ANYONE KNOW WHY MY MOTORS KEEP GETTING FULL OF FLUID ? I PUT NEW SEALS ON MY PUMPHEADS AND THEY STILL LEAK . :angry: IM THINKING ITSW THE O RINGS BUT I DONT KNOW. I BOUGHT 2 NEW MOTORS BUT I DONT WANT TO PUT THEM IN YET UNTIL I FIX THE PROBLEM..
ADVICE PLEASE
 

·
Premium Member
Joined
·
5,323 Posts
one of two things...

1) The o-ring between the gear and block is bad.

2) The seal around the pump shaft is bad...
 

·
Registered
Joined
·
100 Posts
Discussion Starter #3
Originally posted by vegashopper@Dec 15 2003, 09:14 PM
one of two things...

1) The o-ring between the gear and block is bad.

2) The seal around the pump shaft is bad...
IT MUST BE THE O RING THEN HUH.
 

·
Registered
Joined
·
19,959 Posts
Originally posted by vegashopper@Dec 15 2003, 07:14 PM
one of two things...

1) The o-ring between the gear and block is bad.

2) The seal around the pump shaft is bad...
No the steal seal ( aka blow proof) that goes on the shaft on the pump head is bad replace it the o-ring between the gear and the block would mek you lose pressure not make the oil leak into the motor



Last edited by BIGTONY at Dec 15 2003, 11:50 PM
 

·
Registered
Joined
·
544 Posts
tony is correct and if it is an old metal seal replace it with the rubber ones and make sure the metal cap to the old one isn't stuck in the block
 

·
I love hearing "PAPA"
Joined
·
5,779 Posts
Originally posted by 77CADDY@Dec 15 2003, 07:09 PM
DOES ANYONE KNOW WHY MY MOTORS KEEP GETTING FULL OF FLUID ? I PUT NEW SEALS ON MY PUMPHEADS AND THEY STILL LEAK . :angry: IM THINKING ITSW THE O RINGS BUT I DONT KNOW. I BOUGHT 2 NEW MOTORS BUT I DONT WANT TO PUT THEM IN YET UNTIL I FIX THE PROBLEM..
ADVICE PLEASE
OK here's a hit for eveyone.

Slot the block from under the center hole straight down to the very end where the motor mounts.

If the seal leaks again, it will drain out and not into the motor casing.
 

·
Registered
Joined
·
19,959 Posts
Originally posted by Hydros+Dec 16 2003, 01:01 AM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (Hydros @ Dec 16 2003, 01:01 AM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--77CADDY@Dec 15 2003, 07:09 PM
DOES ANYONE KNOW WHY MY MOTORS KEEP GETTING FULL OF FLUID ? I PUT NEW SEALS ON MY PUMPHEADS AND THEY STILL LEAK . :angry:  IM THINKING ITSW THE O RINGS BUT I DONT KNOW. I BOUGHT 2 NEW MOTORS BUT I DONT WANT TO PUT THEM IN YET UNTIL I FIX THE PROBLEM..
                                            ADVICE PLEASE
OK here's a hit for eveyone.

Slot the block from under the center hole straight down to the very end where the motor mounts.

If the seal leaks again, it will drain out and not into the motor casing.[/b][/quote]
have you done this?? it usually would only lead under pressure so i would think it would get in the motor either way????
 

·
I love hearing "PAPA"
Joined
·
5,779 Posts
Originally posted by BIGTONY+Dec 16 2003, 01:12 AM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (BIGTONY @ Dec 16 2003, 01:12 AM)</td></tr><tr><td id='QUOTE'>
Originally posted by [email protected] 16 2003, 01:01 AM
<!--QuoteBegin--77CADDY
@Dec 15 2003, 07:09 PM
DOES ANYONE KNOW WHY MY MOTORS KEEP GETTING FULL OF FLUID ? I PUT NEW SEALS ON MY PUMPHEADS AND THEY STILL LEAK . :angry:  IM THINKING ITSW THE O RINGS BUT I DONT KNOW. I BOUGHT 2 NEW MOTORS BUT I DONT WANT TO PUT THEM IN YET UNTIL I FIX THE PROBLEM..
                                            ADVICE PLEASE

OK here's a hit for eveyone.

Slot the block from under the center hole straight down to the very end where the motor mounts.

If the seal leaks again, it will drain out and not into the motor casing.
have you done this?? it usually would only lead under pressure so i would think it would get in the motor either way????[/b][/quote]
Yes, years ago I have did this. I have not done this to my current blocks.

Maybe I should, I was thinking the seals they make these days were much better than 20 years ago.

It seems the seals would seep at first. At least you would be able to see it is leaking, other wise it might be too late.

I have seen this done elsewhere too, I think on some cars, but just not sure where at.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #10
Originally posted by lowlow90@Dec 16 2003, 02:04 AM
tony is correct and if it is an old metal seal replace it with the rubber ones and make sure the metal cap to the old one isn't stuck in the block
I ALREADY DID REPLACE IT WITH THE RUBBER ONES OND THEY STILL LEAK . SO I GUESS ILL TRY THE O RING AND IF THAT DOESNT WORK ILL HAVE TO CHECK OUT THOSE MOTOR SEALS.
EITHER WAY I HAVE TO GET MY SHIT GOING BECAUSE I HAVENT HIT A SWITCH IN A WEEK AND IM GETTING SWITCH HAPPY :cool:
 

·
I love hearing "PAPA"
Joined
·
5,779 Posts
Originally posted by 77CADDY+Dec 16 2003, 05:26 AM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (77CADDY @ Dec 16 2003, 05:26 AM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--lowlow90@Dec 16 2003, 02:04 AM
tony is correct and if it is an old metal seal replace it with the rubber ones and make sure the metal cap to the old one isn't stuck in the block
I ALREADY DID REPLACE IT WITH THE RUBBER ONES OND THEY STILL LEAK . SO I GUESS ILL TRY THE O RING AND IF THAT DOESNT WORK ILL HAVE TO CHECK OUT THOSE MOTOR SEALS.
EITHER WAY I HAVE TO GET MY SHIT GOING BECAUSE I HAVENT HIT A SWITCH IN A WEEK AND IM GETTING SWITCH HAPPY :cool:[/b][/quote]
Maybe the shaft has a nick on it?
 

·
I love hearing "PAPA"
Joined
·
5,779 Posts
Originally posted by badass 64@Dec 16 2003, 02:08 AM


motorseal kit from prohopper, -problem solved.
I have seen these, but where does the fluid go to if and when it leaks out the pump seal? Is it all collected behind that larger seal?
 

·
Registered
Joined
·
7,083 Posts
yes it is and it has no chance to get by it, i run those myselfe and they're great! ofcourse you'll have to check the o-ring first so it's in good shape then you just put those in and forget about it!
 

·
Registered
Joined
·
100 Posts
Discussion Starter #14
Originally posted by badass 64@Dec 16 2003, 10:59 AM
yes it is and it has no chance to get by it, i run those myselfe and they're great! ofcourse you'll have to check the o-ring first so it's in good shape then you just put those in and forget about it!
I HOPE THE O RING WORKS. HOW MUCH DID YOU PAY FOR THOSE MOTOR SEALS?
 

·
Registered
Joined
·
100 Posts
Discussion Starter #15
Originally posted by Hydros+Dec 16 2003, 10:52 AM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (Hydros @ Dec 16 2003, 10:52 AM)</td></tr><tr><td id='QUOTE'>
Originally posted by [email protected] 16 2003, 05:26 AM
<!--QuoteBegin--lowlow90
@Dec 16 2003, 02:04 AM
tony is correct and if it is an old metal seal replace it with the rubber ones and make sure the metal cap to the old one isn't stuck in the block

I ALREADY DID REPLACE IT WITH THE RUBBER ONES OND THEY STILL LEAK . SO I GUESS ILL TRY THE O RING AND IF THAT DOESNT WORK ILL HAVE TO CHECK OUT THOSE MOTOR SEALS.
EITHER WAY I HAVE TO GET MY SHIT GOING BECAUSE I HAVENT HIT A SWITCH IN A WEEK AND IM GETTING SWITCH HAPPY :cool:
Maybe the shaft has a nick on it?[/b][/quote]
THE SHAFTS LOOK GOOD.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #16
Originally posted by 77CADDY+Dec 16 2003, 12:41 PM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (77CADDY @ Dec 16 2003, 12:41 PM)</td></tr><tr><td id='QUOTE'>
Originally posted by [email protected] 16 2003, 10:52 AM
Originally posted by [email protected] 16 2003, 05:26 AM
<!--QuoteBegin--lowlow90
@Dec 16 2003, 02:04 AM
tony is correct and if it is an old metal seal replace it with the rubber ones and make sure the metal cap to the old one isn't stuck in the block

I ALREADY DID REPLACE IT WITH THE RUBBER ONES OND THEY STILL LEAK . SO I GUESS ILL TRY THE O RING AND IF THAT DOESNT WORK ILL HAVE TO CHECK OUT THOSE MOTOR SEALS.
EITHER WAY I HAVE TO GET MY SHIT GOING BECAUSE I HAVENT HIT A SWITCH IN A WEEK AND IM GETTING SWITCH HAPPY :cool:

Maybe the shaft has a nick on it?
THE SHAFTS LOOK GOOD.[/b][/quote]
DAM I FOUND OUT WHAT THE PROBLEM WAS, THIS VATO THAT I BOUGHT THE PUMPHEAD SEALS FROM SOLD ME THE WRONG ONES THEY FIT LOOSE AROUND THE SPLINE, NOW I GOT TO WAIT UNTIL I GET THE RIGHT ONES. :uh:
THANK FOR THE REPLIES HOMIES
 

·
I love hearing "PAPA"
Joined
·
5,779 Posts
Originally posted by 82 REGAL@Feb 21 2004, 07:32 PM
Anyone ever use one of these Aluminum "BLOW PROOF SEALS"?
I have an old Lexus block/pump with that, I was wondering too about these, seems these would wear out faster, but never blow like the seals.

Otherwise, I thought the idea had merit.
 

·
Registered
Joined
·
7,083 Posts
Originally posted by 77CADDY+Dec 16 2003, 07:40 PM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (77CADDY @ Dec 16 2003, 07:40 PM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--badass 64@Dec 16 2003, 10:59 AM
yes it is and it has no chance to get by it, i run those myselfe and they're great! ofcourse you'll have to check the o-ring first so it's in good shape then you just put those in and forget about it!
I HOPE THE O RING WORKS. HOW MUCH DID YOU PAY FOR THOSE MOTOR SEALS?[/b][/quote]
i got a bunch of them for free from "patrik" on here, he's the dude that runs the hydroshop in my signature...
 

·
Registered
Joined
·
1,317 Posts
Originally posted by Hydros+Feb 22 2004, 09:04 AM--></span><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (Hydros @ Feb 22 2004, 09:04 AM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin--82 REGAL@Feb 21 2004, 07:32 PM
Anyone ever use one of these Aluminum "BLOW PROOF SEALS"?
I have an old Lexus block/pump with that, I was wondering too about these, seems these would wear out faster, but never blow like the seals.

Otherwise, I thought the idea had merit.[/b][/quote]
Anyone else ever use these? Did they last longer than the plastic/rubber ones?
 
1 - 20 of 20 Posts
Top